incubator-isis-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Haywood <dkhayw...@gmail.com>
Subject Added the enforcer plugin
Date Tue, 02 Nov 2010 22:51:53 GMT
Kevin just mailed me to say that his attempt to do a full build of the 
site docs (mvn site-deploy -P standard,site-all,deploy-local) failed.

Suspecting that this might be an inconsistency in our environments, I've 
just added in a reference to the Maven enforcer plugin, which checks 
Java, Maven and requires all plugin versions to be specified.

As it turned out, there was only one plugin version missing, but even so 
it different JVMs or Maven versions might account for differences in 
behaviour.

I've set the enforcer to require reasonably up-to-date versions of both 
JVM (1.6.0-21) and Maven (2.2.1), so you might need to upgrade your own 
environments.

To check... do an svn up, and run "mvn validate".

Thx
Dan



Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message