incubator-imperius-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Rupert" <christian.rup...@web.de>
Subject Imperius Installation Problems
Date Wed, 02 Jun 2010 13:34:50 GMT
Hi there,

 

my name is Christian and I´m working for a research project at the
University of Pforzheim, Germany.

My general task is to find ways how to implement policy hierarchies and
their enforcements.

Luckily I found your Imperius project while surfing the net.

I already installed OpenPegasus as CIMOM and now wanted to combine it with
Imperius.

Being a newbie to WBEM/CIM I would be happy if you could help me.

No matter which building part I try (JavaSPL, SPL Editor, Client Side
Provider or Provider), it fails.

(Attached you can find a copy of the log.txt of the installation)

It seems like something is wrong with my classpath variable, because e.g.
the class ToUInt8.java has a package import:

import org.sblim.wbem.cim.UnsignedInt8;

which is not able being found.

The class UnsignedInt8 lies in my:

${PEGASUS_ROOT}/src/Pegasus/ProviderManager2/JMPI/org/pegasus/JMPI/

Which is a part of my environment settings:

 

export PEGASUS_ROOT=/home/rupchr/pegasus/

export PEGASUS_HOME=/home/rupchr/pegasus_home

export PEGASUS_PLATFORM=LINUX_IX86_GNU

export PEGASUS_DISABLE_PROV_USERCTXT=true

export JAVA_HOME=/usr/lib/jvm/java-6-openjdk

export PEGASUS_ENABLE_JMPI_PROVIDER_MANAGER=true

export PEGASUS_JVM=sun

export PEGASUS_JAVA_ARCH=i386

export PEGASUS_JAVA_TYPE=client

export
CLASSPATH=${CLASSPATH}:${PEGASUS_HOME}/lib/JMPIImpl.jar:${PEGASUS_HOME}/lib/
imperius-cimsplprovider-1.0.0.jar:${PEGASUS_HOME}/lib/imperius-splcore-1.0.0
.jar:${PEGASUS_HOME}/lib/imperius-cimsplcommon-1.0.0.jar:${PEGASUS_HOME}/lib
/antlr.jar:/home/rupchr/pegasus/src/Pegasus/ProviderManager2/JMPI/:/home/rup
chr/pegasus/src/Pegasus/ProviderManager2/JMPI/org

export PEGASUS_ENABLE_CMPI_PROVIDER_MANAGER=true

export PEGASUS_ENABLE_JMPI_PROVIDER_MANAGER=true

export PEGASUS_DEBUG=1

export JAVA_SDK=/usr/lib/jvm/java-6-openjdk

export JAVA_SDKINC=$JAVA_SDK/include

export
LD_LIBRARY_PATH=$PEGASUS_HOME/lib:$JAVA_SDK/jre/lib/i386/server:$JAVA_SDK/jr
e/lib/i386/native_threads:$JAVA_SDK/jre/lib/i386:$PEGASUS_HOME/lib/imperius-
cimsplprovider-1.0.0.jar:$PEGASUS_HOME/lib/imperius-splcore-1.0.0.jar:$PEGAS
US_HOME/lib/imperius-cimsplcommon-1.0.0.jar:$PEGASUS_HOME/lib/antlr.jar

export PATH=$JAVA_SDK/bin:$PATH:$PATH:$PEGASUS_HOME/bin

 

Perhaps there is another problem with my environment settings?

Am I right with my guess, that the Classpath variable is the point of
failure? seems to be right in my understanding.

 


Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message