incubator-imperius-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Rupert" <christian.rup...@web.de>
Subject Error while executing Policies
Date Thu, 17 Jun 2010 14:53:43 GMT
Hi there,

 

I get an error while executing the cimspl-samples script: cimsplcmdline.sh
with the following options:

 

cimsplcmdline.sh -x ./samples/policies/testElement1Policy.spl

CIMSPL Client

Established Connection

exec policy./samples/policies/testElement1Policy.spl

cimObjectPath: root/cimv2:CIM_SPLPolicyRule

Error: CIM_ERR_FAILED

 

=>but the Provider and the Class are registered via the cimmof.

=>there are instances of the class TestElement to which the
testElement1Policy.spl relates to.

 

There are no further details of the error message.

The problem might be related to the following:

I can extend my CIM Schema with:

cimmof -n root/cimv2
./Imperius/trunk/imperius-cimsplprovider/resources/mofs/CIM_SPLPolicyRule.mo
f

 

But when I try to get an Instance of the class, there occurs a 400 Bad
Request because of an illegal value for the attribute
Instancename.Classname:

cimcli gi CIM_SPLPolicyRule

cimcli Pegasus Exception: HTTP Error (400 Bad Request): CIMError=
"request-not-valid" Detail="Semantic error: on line 11:Illegal value for
INSTANCE.CLASSNAME attribute".Cmd=gi Object=CIM_SPLPolicyRule

 

While trying to create an instance I get an error like this one:

cimcli ci CIM_SPLPolicyRule

cimcli CIMException: Cmd=ci Object= CIM_SPLPolicyRule Code=1

CIM_ERR_FAILED: Java caused an exception: [no further details]

 

Really need some help, any ideas?

 

Thank you in advance,

Christian R.

University of Applied Sciences Pforzheim 

 

 

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message