incubator-imperius-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Neeraj Joshi <jnee...@us.ibm.com>
Subject Re: Eclipse Editor for SPL checked in
Date Tue, 15 Jan 2008 19:14:10 GMT
Hi Erik,
Couple of things
1) Are you just building the samples modules or the whole thing?
2) Not sure if you looked at the build instructions for the editor on the 
website but basically you need to do the following:

a.      First configure the maven repository with eclipse plugins. To do 
this on a command prompt run mvn eclipse:make-artifacts -DeclipseDir= < 
ECLIPSE_HOME > 
b.      Make sure ANTLR_HOME is set 
c.      Run ant all to build both the runtime and the site 

Atleast from the error that I see in your email it seems like the eclipse 
platform maven repository artifact does not exist

Let me know if that doesn't resolve the issue
Thanks
Neeraj


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
"Those are my principles. If you don't like them I have others." 

http://incubator.apache.org/imperius
 
Neeraj Joshi
Autonomic Computing Policy Development
Tivoli, IBM

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~



Craig L Russell <Craig.Russell@Sun.COM> 
Sent by: Craig.Russell@Sun.COM
01/15/2008 01:57 PM
Please respond to
imperius-dev@incubator.apache.org


To
imperius-dev@incubator.apache.org
cc

Subject
Re: Eclipse Editor for SPL checked in






Erik,

As Neeraj points out, your messages are not getting through.

Neeraj,

I tried to build the samples by cd imperius/trunk; mvn and got this:

[INFO] Building jar: /Users/clr/apache/imperius/trunk/javaspl-samples/ 
target/javaspl-samples-1.0.0-SNAPSHOT.jar
[INFO] [install:install]
[INFO] Installing /Users/clr/apache/imperius/trunk/javaspl-samples/ 
target/javaspl-samples-1.0.0-SNAPSHOT.jar to /Users/clr/.m2/repository/ 
imperius/javaspl-samples/1.0.0-SNAPSHOT/javaspl-samples-1.0.0- 
SNAPSHOT.jar
[INFO] 
----------------------------------------------------------------------------
[INFO] Building imperius-spleditorcore
[INFO]    task-segment: [install]
[INFO] 
----------------------------------------------------------------------------
[INFO] [resources:resources]
[INFO] Using default encoding to copy filtered resources.
[INFO] artifact org.eclipse.platform:org.eclipse.platform: checking 
for updates from central
[INFO] 
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] 
------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

No versions are present in the repository for the artifact with a 
range [3.3.0,)
   org.eclipse.platform:org.eclipse.platform:jar:null

from the specified remote repositories:
   central (http://repo1.maven.org/maven2)

Craig

On Jan 15, 2008, at 12:15 AM, Erik Bengtson wrote:

>
> --   BlackBerry® from Mobistar    ---
>
> -----Original Message-----
> From: Neeraj Joshi <jneeraj@us.ibm.com>
>
> Date: Tue, 15 Jan 2008 02:13:12
> To:imperius-dev@incubator.apache.org
> Subject: Eclipse Editor for SPL checked in
>
>
> Hi All,
> I have checked in the editor code. I have also updated the website 
> with
> instructions to build and use the editor. Let me know if you face any
> problems.
> Thanks
> Neeraj
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> "Those are my principles. If you don't like them I have others."
>
> http://incubator.apache.org/imperius
>
> Neeraj Joshi
> Autonomic Computing Policy Development
> Tivoli, IBM
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Craig Russell
Architect, Sun Java Enterprise System http://java.sun.com/products/jdo
408 276-5638 mailto:Craig.Russell@sun.com
P.S. A good JDO? O, Gasp!



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message