incubator-hcatalog-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "j.barrett Strausser" <j.barrett.straus...@gmail.com>
Subject Re: Building HCatalog 0.5.0 from source
Date Thu, 02 May 2013 16:42:13 GMT
vagrant@ubuntu-12:~$ uname -a
Linux ubuntu-12 3.5.0-23-generic #35~precise1-Ubuntu SMP Fri Jan 25
17:13:26 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

vagrant@ubuntu-12:~$ java -version
java version "1.6.0_27"
OpenJDK Runtime Environment (IcedTea6 1.12.3) (6b27-1.12.3-0ubuntu1~12.04.1)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

I'm building on trunk.



On Thu, May 2, 2013 at 11:20 AM, Alan Gates <gates@hortonworks.com> wrote:

> As long as you don't care about the javadocs you can ignore this.  I'm
> curious what platform and JVM you're building with though, and are you
> building trunk or a branch?  I'm not seeing any javadoc failures when I
> build.
>
> Alan.
>
> On Apr 29, 2013, at 9:30 PM, j.barrett Strausser wrote:
>
> > BUILD FAILED
> > /tmp/staging/hcatalog-src-0.5.0-incubating/build.xml:213: Javadoc
> comments contain warnings.
> >
> > Assuming this can be safely ignored?
> >
> > -b
> >
> >
> >
> > On Tue, Apr 30, 2013 at 12:30 AM, j.barrett Strausser <
> j.barrett.strausser@gmail.com> wrote:
> > Finally stumbled across this : https://reviews.apache.org/r/9641/
> >
> > Looks like the documentation was out of date.
> >
> > Now I'm receiving -
> >
> >
> > -b
> >
> >
> > On Mon, Apr 29, 2013 at 9:10 PM, j.barrett Strausser <
> j.barrett.strausser@gmail.com> wrote:
> > I had a previous version of HCat working. I'm rebuilding a machine and
> have run across the following :
> >
> > Following the directions listed at
> http://incubator.apache.org/hcatalog/docs/r0.5.0/install.html#Server+Installation+from+Source
> >
> > hduser@ubuntu-12:/tmp/staging/hcatalog-src-0.5.0-incubating$ ant
> -Dhcatalog.version=0.5.0 -Dforrest.home=/opt/forrest tar
> > Buildfile: /tmp/staging/hcatalog-src-0.5.0-incubating/build.xml
> >
> > BUILD FAILED
> > Target "tar" does not exist in the project "hcatalog".
> >
> > Total time: 0 seconds
> >
> > Trying a different target either 'jar' or 'package' gives the following.
> >
> > 1 required artifact is missing.
> >
> > for artifact:
> >   org.apache.hcatalog:hcatalog-server-extensions:jar:0.5.0-incubating
> >
> >
> >
> > I see lots of traffic on the dev list concerning these issues. Examples
> below, but I don't have enough context to sort them out.
> >
> >
> > Are the instructions out of date or do I have some broken code somewhere.
> >
> > thanks
> >
> > -b
> >
> >
> >
> > --
> >
> >
> > https://github.com/bearrito
> > @barrettsmash
> >
> >
> >
> > --
> >
> >
> > https://github.com/bearrito
> > @barrettsmash
> >
> >
> >
> > --
> >
> >
> > https://github.com/bearrito
> > @barrettsmash
>
>


-- 


https://github.com/bearrito
@barrettsmash

Mime
View raw message