incubator-hcatalog-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Gates <ga...@hortonworks.com>
Subject Re: ERROR 1070: Could not resolve org.apache.hcatalog.pig.HCatLoader
Date Fri, 24 Aug 2012 16:44:34 GMT
Also your PIG_CLASSPATH has to point to the directory that hive-site.xml is in, not to the
hive-site.xml file itself.

Alan.

On Aug 24, 2012, at 9:10 AM, Petr Babkin wrote:

> Thanks, Aniket and Vandana,
> 
> after adding the jars to PIG_CLASSPATH, I'm getting:
> 
> WARN  org.apache.hadoop.hive.conf.HiveConf - hive-site.xml not found on CLASSPATH
> ERROR org.apache.pig.tools.grunt.Grunt - ERROR 2998: Unhandled internal error. com/facebook/fb303/FacebookService$Iface
> 
> though my PIG_CLASSPATH has /etc/hive/conf.dist/hive-site.xml added.
> 
> Vandana, could you please be more specific on what HCatalog configuration needs to be
done?
> 
> Many thanks!
> 
> Regards,
> Petr Babkin
> 
> On Thu, Aug 23, 2012 at 7:02 PM, Aniket Mokashi <aniket486@gmail.com> wrote:
> 1. Make sure HCatalog jar is in the class path (named hcatalog*.jar)
> 2. Make sure your pig is running with -Dudf.import.list=org.apache.hcatalog.pig. This
is how pig finds the package prefix for HCatLoader
> 
> Workaround for 2 is- in your pig script- replace HCatLoader by org.apache.hcatalog.pig.HCatLoader.
> 
> I assume HDP is doing all that already. So, I suspect something else is responsible here.
> 
> Thanks,
> Aniket
> 
> On Thu, Aug 23, 2012 at 3:47 PM, Vandana Ayyalasomayajula <avandana@yahoo-inc.com>
wrote:
> Hi Petr, 
> 
> I am thinking that this issue is related to class path. You need to have the HCatalog,
hive jars in your PIG_CLASSPATH env variable. 
> 
> From a previous post in the user list, the following this are required in the class path.
> 
> Minimum set-
> /share/hcatalog/hcatalog*.jar:
> /share/hcatalog/lib/hive-metastore*.jar:
> /share/hcatalog/lib/thrift-fb303-*.jar:
> /share/hcatalog/lib/libthrift*.jar:
> /share/hcatalog/lib/hive-exec-*.jar
> +HCatalog configuration (hive-site et al)…
> 
> Thanks
> Vandana
> 
> 
> On Aug 23, 2012, at 12:49 PM, Petr Babkin wrote:
> 
>> I am getting the following error when trying to load the table from HCatalog into
pig:
>> 
>> ERROR org.apache.pig.tools.grunt.Grunt - ERROR 1070: Could not resolve org.apache.hcatalog.pig.HCatLoader
using imports: [, org.apache.pig.builtin., org.apache.pig.impl.builtin.]
>> 
>> This is all running on HDP, so I am surprised why the resolution fails. Googling
around this issue didn't bring any result. 
>> 
>> Thanks.
>> 
>> -- 
>> Regards,
>> Petr Babkin
>> Ontologist, Revelytix Inc.
>> 
> 
> Vandana Ayyalasomayajula
> 
> 
> 
> 
> 
> 
> -- 
> "...:::Aniket:::... Quetzalco@tl"
> 
> 
> 
> -- 
> Regards,
> Petr Babkin
> Ontologist, Revelytix Inc.
> 


Mime
View raw message