incubator-hcatalog-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carl Steinbach <c...@cloudera.com>
Subject Re: Unable to install hcatalog
Date Tue, 17 Jan 2012 22:33:45 GMT
Hi Zaki,

Does this file actually exist?

>> /usr/local/apache-forrest-0.9/install/bin/forrest

On Tue, Jan 17, 2012 at 1:05 PM, zaki <zaki.gonewiththewind@gmail.com>wrote:

> Hi Carl
>
> As per your suggestion i tried to build the tarball according to the
> instruction available in RELEASE_NOTES.txt. I am getting the below error
> when i try to execute the command
>
> COMMAND:
>
> ant tar -Dforrest.home=/usr/local/apache-forrest-0.9/install
> -Dhcatalog.version=0.2.0
>
> Error:
>
> /root/HCatalog_dump/hcatalog-src-0.2.0-incubating/build.xml:372: Execute
> failed: java.io.IOException: Cannot run program
> "/usr/local/apache-forrest-0.9/install/bin/forrest" (in directory
> "/root/HCatalog_dump/hcatalog-src-0.2.0-incubating/src/docs"):
> java.io.IOException: error=2, No such file or directory
>         at java.lang.ProcessBuilder.start(ProcessBuilder.java:460)
>         at java.lang.Runtime.exec(Runtime.java:593)
>         at
> org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(Execute.java:862)
>
> JAVA SDK version
>
>  #java -version
> java version "1.6.0_21"
> Java(TM) SE Runtime Environment (build 1.6.0_21-b06)
> Java HotSpot(TM) 64-Bit Server VM (build 17.0-b16, mixed mode)
>
> Cloudera's Distribution of HADOOP Version (which is installed using
> Cloudera's SCM)
>
> # hadoop version
> Hadoop 0.20.2-cdh3u2
> Subversion file:///tmp/topdir/BUILD/hadoop-0.20.2-cdh3u2 -r
> 95a824e4005b2a94fe1c11f1ef9db4c672ba43cb
> Compiled by root on Thu Oct 13 21:50:22 PDT 2011
> From source with checksum 644e5db6c59d45bca96cec7f220dda51
>
> Probably the information provided above might help to diagnose the issue.
>
> Thanks and Regards
>       Zaki
>
>
>
>
> On Mon, Jan 16, 2012 at 5:30 PM, Carl Steinbach <carl@cloudera.com> wrote:
>
>> Hi Zaki,
>>
>> You may be able to get this to work by forcing the installation of the
>> hcatalog RPM
>> using the --force option, but there's also a good chance that this will
>> break
>> your Hive installation, and may also leave you with a broken HCatalog
>> installation.
>>
>> The basic problem is that the HCatalog RPM should not install Hive
>> artifacts, but
>> is forced to because Apache Hive RPMs don't exist. I filed HCATALOG-217
>> to track
>> this issue.
>>
>> Until this ticket gets resolved I think your best bet is to try using the
>> HCatalog tarball.
>>
>> Thanks.
>>
>> Carl
>>
>> On Sun, Jan 15, 2012 at 10:29 PM, zaki <zaki.gonewiththewind@gmail.com>wrote:
>>
>>> Hi All
>>>
>>> The following is the Error i am receiving when i tried to install
>>> Hcatalog over the Cloudera's distribution of cloudera on a 5 machine
>>> cluster.
>>>
>>> Atlas:~ # rpm -ivh hcatalog-0.2.0_incubating-1.i386.rpm
>>> Preparing...                ###########################################
>>> [100%]
>>>         file /usr/bin/hive from install of
>>> hcatalog-0.2.0_incubating-1.i386 conflicts with file from package
>>> hadoop-hive-0.7.1+42.27-2.noarch
>>> Atlas:~ #
>>>
>>> Cloudera's SCM Distribution already installed hive and i have configured
>>> it to use mysql as external database. I have tested the hive installation
>>> by creating a table and ran query in My SQL Database to verify the same.
>>>
>>> Thanks in advance
>>>      Zaki
>>>
>>>
>>>
>>>
>>
>

Mime
View raw message