incubator-hcatalog-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yin Huai <huaiyin....@gmail.com>
Subject installation issues
Date Sat, 08 Oct 2011 15:20:35 GMT
Hello,

When I trying to build HCatalog using ant tar
-Dforrest.home=/path/to/forrest/install -Dhcatalog.version=0.2.0, I got an
error shown as follows

hive.jar:

jar:
  [taskdef] Could not load definitions from resource
net/sf/antcontrib/antcontrib.properties. It could not be found.

BUILD FAILED
/home/yhuai/app/hcatalog-src-0.2.0-incubating/build.xml:239: The following
error occurred while executing this line:
/home/yhuai/app/hcatalog-src-0.2.0-incubating/hive/external/build.xml:196:
The following error occurred while executing this line:
/home/yhuai/app/hcatalog-src-0.2.0-incubating/hive/external/build.xml:130:
The following error occurred while executing this line:
/home/yhuai/app/hcatalog-src-0.2.0-incubating/hive/external/shims/build.xml:26:
The following error occurred while executing this line:
/home/yhuai/app/hcatalog-src-0.2.0-incubating/hive/external/build-common.xml:85:
Source resource does not exist:
/home/yhuai/app/hcatalog-src-0.2.0-incubating/hive/ivy/libraries.properties

Total time: 0 seconds

I checked the build.xml in the root directory of HCatalog, the property of
"hive.root" has been set to "${basedir}/hive/external". Also, in the
build-common.xml of hive, the property of "ivy.conf.dir" has been set to
"${hive.root}/ivy". But based on the error info, it seems that the property
of "hive.root" has been overridden during build procedure.

Did I miss some thing or did something incorrect?

Also, when I was following the source installation instruction on page
http://incubator.apache.org/hcatalog/docs/r0.2.0/install.html and using the
command scripts/hcat_server_install.sh -r *root* -d *dbroot* -h *hadoop_home
* -p *portnum *to install the server, there were some errors...
cp: cannot stat `./etc/*': No such file or directory
cp: cannot stat `./libexec/*': No such file or directory
cp: cannot stat `./sbin/*': No such file or directory
cp: cannot stat `./share/*': No such file or directory
rm: cannot remove `/usr/local/hcat//share/hcatalog/conf': No such file or
directory
ln: creating symbolic link `/usr/local/hcat//share/hcatalog/conf': No such
file or directory
cp: cannot stat `/usr/local/hcat//etc/hcatalog/proto-hive-site.xml': No such
file or directory
chmod: cannot access `/usr/local/hcat//etc/hcatalog/hive-site.xml': No such
file or directory
scripts/hcat_server_install.sh: line 146:
/usr/local/hcat//etc/hcatalog/hcat-env.sh: No such file or directory

Actually directories etc, libexec, sbin and share do not exist in the root
directory of HCatalog.

Thanks,

Yin Huai

Mime
View raw message