incubator-hcatalog-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julien Le Dem (Commented) (JIRA)" <>
Subject [jira] [Commented] (HCATALOG-10) Shouldn't assume the secure hadoop installation
Date Sat, 17 Dec 2011 01:16:30 GMT


Julien Le Dem commented on HCATALOG-10:

You are correct, a class in the package would be more appropriate.
In fact the isSecurityEnabled method itself is a good candidate.
try {
  Security.getInstance().handleSecurity(job, outputJobInfo, client, conf, harRequested);
} catch (NoSuchMethodException e) {"Security is not supported by this version of hadoop.");
Then if it's present we are going to use it to check if security is enabled.
I'm attaching an updated patch: HCAT-10_a.patch 
> Shouldn't assume the secure hadoop installation
> -----------------------------------------------
>                 Key: HCATALOG-10
>                 URL:
>             Project: HCatalog
>          Issue Type: Bug
>    Affects Versions: 0.1
>            Reporter: Devaraj Das
>            Assignee: Julien Le Dem
>         Attachments: HCAT-10.patch, HCAT-10_a.patch
> HCatalog currently only builds against Hadoop 20S. It should successfully build against
hadoop-0.20 as well. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message