incubator-hcatalog-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Francis Liu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HCATALOG-64) Refactor HCatTableInfo, JobInfo and OutputJobInfo
Date Tue, 26 Jul 2011 18:55:09 GMT

     [ https://issues.apache.org/jira/browse/HCATALOG-64?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Francis Liu updated HCATALOG-64:
--------------------------------

    Attachment: HCatTableInfo_JobInfo_OutputJobInfo_2.patch

third time's the charm

> Refactor HCatTableInfo, JobInfo and OutputJobInfo
> -------------------------------------------------
>
>                 Key: HCATALOG-64
>                 URL: https://issues.apache.org/jira/browse/HCATALOG-64
>             Project: HCatalog
>          Issue Type: Improvement
>            Reporter: Francis Liu
>            Assignee: Francis Liu
>         Attachments: HCatTableInfo_JobInfo_OutputJobInfo_2.patch
>
>
> These classes and their roles has become convoluted. HCatTableInfo should be an HCat
abstraction of table and thus not have any job specific information and should not contain
different information depending on usage. *JobInfo classes should contain job specific information
(user provided, derived from metastore info, etc). Since *JobInfo contains such information
it should be the object which is passed to HCatInputFormat.setInput and HCatInputFormat.setOutput.
Also JobInfo should be renamed to InputJobInfo for consistency and clarity. Also there needs
to be a way to pass implementation specific configuration information down to the actual storage
driver.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message