incubator-hama-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Yoon" <edwardy...@apache.org>
Subject Re: [DISCUSS] - Feedback about Hama 0.2.0-incubating RC1
Date Tue, 15 Mar 2011 01:25:58 GMT
Hi,

> While doing that I found the commons-el-from-jetty dependency and could not
> find a pointer to the project (nor in Maven repositories).
> Does anyone have any clue about it?

The jetty and http related dependencies were included for future web
monitoring tool. However, I think it seems better to remove them from
dependencies list at this time.

Unnecessary dependencies:

 - commons-el-from-jetty-5.1.4.jar
 - commons-math-1.1.jar
 - jetty-6.1.14.jar
 - jetty-util-6.1.14.jar
 - libthrift-r771587.jar

> Also the Commons CLI is at 2.0-SNAPSHOT and it's not good to have
> dependencies from SNAPSHOTS as you can imagine, so I switched my local copy
> to version 1.2 and everything is still working.
> Once we get rid of the above issues I can provide a new patch to Maven POM.

+1

On Tue, Mar 15, 2011 at 2:44 AM, Tommaso Teofili
<tommaso.teofili@gmail.com> wrote:
> Hi again,
> I am going through Maven POM to make sure it's compliant with Maven good
> practices and release rules (even if we're not going to make the release
> through Maven at the moment).
> While doing that I found the commons-el-from-jetty dependency and could not
> find a pointer to the project (nor in Maven repositories).
> Does anyone have any clue about it?
> Also the Commons CLI is at 2.0-SNAPSHOT and it's not good to have
> dependencies from SNAPSHOTS as you can imagine, so I switched my local copy
> to version 1.2 and everything is still working.
> Once we get rid of the above issues I can provide a new patch to Maven POM.
> Cheers,
> Tommaso
>
> 2011/3/14 Tommaso Teofili <tommaso.teofili@gmail.com>
>
>> As far as I can see we can go making a new release candidate and vote for
>> it.
>> Cheers,
>> Tommaso
>>
>> 2011/3/14 Edward J. Yoon <edwardyoon@apache.org>
>>
>> Other comments?
>>>
>>> On Mon, Mar 14, 2011 at 3:09 AM, Tommaso Teofili
>>> <tommaso.teofili@gmail.com> wrote:
>>> > Correct, the fix to miniBSPCluster bug made it work again.
>>> > Cheers,
>>> > Tommaso
>>> >
>>> > 2011/3/13 Chia-Hung Lin <clin4j@googlemail.com>
>>> >
>>> >> I download the build version from [1], but I notice that it doesn't
>>> >> contain the pom.xml which is required by maven when executing e.g.
>>> >> `mvn clean package`
>>> >>
>>> >> But when testing with the latest trunk in svn, the execution of
>>> >> command `mvn clean package` works well.
>>> >>
>>> >> [INFO] Building jar:
>>> >> /home/user/hama/target/hama-0.2.0-incubating-SNAPSHOT.jar
>>> >> [INFO]
>>> >>
>>> ------------------------------------------------------------------------
>>> >> [INFO] BUILD SUCCESS
>>> >> [INFO]
>>> >>
>>> ------------------------------------------------------------------------
>>> >> [INFO] Total time: 1:38.758s
>>> >> [INFO] Finished at: Sun Mar 13 18:05:42 CST 2011
>>> >> [INFO] Final Memory: 13M/32M
>>> >> [INFO]
>>> >>
>>> ------------------------------------------------------------------------
>>> >>
>>> >>
>>> >> 2011/3/11 Edward J. Yoon <edwardyoon@apache.org>:
>>> >> > Thanks for the comment.
>>> >> >
>>> >> > I guess it's related with miniBSPCluster bug. I'll look at it!
>>> >> >
>>> >> > On Fri, Mar 11, 2011 at 2:01 AM, Tommaso Teofili
>>> >> > <tommaso.teofili@gmail.com> wrote:
>>> >> >> running 'mvn clean package' I got one test failing:
>>> >> >>
>>> >> >> *Failed tests:
>>> >> >>>   testSync(org.apache.hama.bsp.TestBSPPeer)
>>> >> >>>   ....
>>> >> >>>   junit.framework.AssertionFailedError: Fail to launch
groom
>>> server.*
>>> >> >>
>>> >> >>
>>> >> >> I will try to work on it in the weekend so if we have also
other
>>> issues
>>> >> to
>>> >> >> work on I'd wait that to be fixed and prepare another RC.
>>> >> >> Cheers,
>>> >> >> Tommaso
>>> >> >>
>>> >> >>
>>> >> >> 2011/3/9 Edward J. Yoon <edwardyoon@apache.org>
>>> >> >>
>>> >> >>> I missed one issue HAMA-339
>>> >> >>>
>>> >> >>> On Wed, Mar 9, 2011 at 9:19 AM, Edward J. Yoon <
>>> edwardyoon@apache.org>
>>> >> >>> wrote:
>>> >> >>> > Last night, I received a mail that this is not work
on
>>> >> Cygwin/Windows7.
>>> >> >>> >
>>> >> >>> > By the way, should hama work on windows also?
>>> >> >>> >
>>> >> >>> > Thanks.
>>> >> >>> >
>>> >> >>> > On Mon, Mar 7, 2011 at 6:05 PM, Tommaso Teofili
>>> >> >>> > <tommaso.teofili@gmail.com> wrote:
>>> >> >>> >> Hi all,
>>> >> >>> >> please download, check and test the Hama 0.2.0-incubating
RC1 at
>>> >> [1].
>>> >> >>> >> Feedback about it is welcome, especially from
existing
>>> committers.
>>> >> >>> >> Let's discuss here about any issues raised.
>>> >> >>> >> The vote thread will be open once this "review"
has finished.
>>> >> >>> >> Cheers,
>>> >> >>> >> Tommaso
>>> >> >>> >>
>>> >> >>> >>
>>> >> >>> >> [1] : http://people.apache.org/~edwardyoon/dist/0.2.0/
>>> >> >>> >>
>>> >> >>> >
>>> >> >>> >
>>> >> >>> >
>>> >> >>> > --
>>> >> >>> > Best Regards, Edward J. Yoon
>>> >> >>> > http://blog.udanax.org
>>> >> >>> > http://twitter.com/eddieyoon
>>> >> >>> >
>>> >> >>>
>>> >> >>>
>>> >> >>>
>>> >> >>> --
>>> >> >>> Best Regards, Edward J. Yoon
>>> >> >>> http://blog.udanax.org
>>> >> >>> http://twitter.com/eddieyoon
>>> >> >>>
>>> >> >>
>>> >> >
>>> >> >
>>> >> >
>>> >> > --
>>> >> > Best Regards, Edward J. Yoon
>>> >> > http://blog.udanax.org
>>> >> > http://twitter.com/eddieyoon
>>> >> >
>>> >>
>>> >>
>>> >>
>>> >> --
>>> >> ChiaHung Lin @ nuk, tw.
>>> >>
>>> >
>>>
>>>
>>>
>>> --
>>> Best Regards, Edward J. Yoon
>>> http://blog.udanax.org
>>> http://twitter.com/eddieyoon
>>>
>>
>>
>



-- 
Best Regards, Edward J. Yoon
http://blog.udanax.org
http://twitter.com/eddieyoon

Mime
View raw message