incubator-hama-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Yoon (JIRA)" <>
Subject [jira] Commented: (HAMA-86) Implements generic load/save operations in hama
Date Wed, 22 Oct 2008 12:20:44 GMT


Edward J. Yoon commented on HAMA-86:

>> so I suggest that let HamaAdmin just keep all the aliases of the matrices in HBase.

Yes, I agree with you.

>> And add a method like "boolean saveAsFile(Path path, OutputFormat format);" to deal
with file I/O of matrices. 

That's good idea.

> Implements generic load/save operations in hama
> -----------------------------------------------
>                 Key: HAMA-86
>                 URL:
>             Project: Hama
>          Issue Type: Improvement
>          Components: implementation
>    Affects Versions: 0.1.0
>            Reporter: Samuel Guo
>             Fix For: 0.1.0
> we need a generic "pathname" class to identify the input & output.
>  "pathname" can contain two parts: one is scheme, such as HBASE or HDFS; one will be
the actual name, such as table name in HBase, filename in HDFS.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message