incubator-hama-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Yoon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HAMA-67) Consider refactoring the overall design
Date Mon, 22 Sep 2008 13:24:44 GMT

    [ https://issues.apache.org/jira/browse/HAMA-67?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12633247#action_12633247
] 

Edward J. Yoon commented on HAMA-67:
------------------------------------

Renaming:

AdditionMap.java -> Add1DLayoutMap.java
AdditionReduce.java -> Add1DLayoutReduce.java 
MultiplicationMap.java -> Mult1DLayoutMap.java
MultiplicationReduce.java -> Mult1DLayoutReduce.java


> Consider refactoring the overall design 
> ----------------------------------------
>
>                 Key: HAMA-67
>                 URL: https://issues.apache.org/jira/browse/HAMA-67
>             Project: Hama
>          Issue Type: Improvement
>          Components: implementation
>            Reporter: Edward J. Yoon
>            Assignee: Edward J. Yoon
>             Fix For: 0.1.0
>
>
> - Map datum shoulde be <IntWritable, VectorWritable>.
> - VectorWritable should returns Vector object.
> - Vector interface, AbstractVector, DenseVector seems appropriate.
> - DenseMatrix and DenseVector operation methods should returns DenseMatrix and DenseVector.
> - Matrix type should be declared by constructor.
> - AbstractMatrix.execute() method should be moved to the utility class.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message