incubator-hama-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Yoon" <edwardy...@apache.org>
Subject Re: Interface re-thinking
Date Wed, 20 Aug 2008 23:11:48 GMT
I quite agree with you. The MatrixInterface should be Matrix,
Implement classes should be ***Matrix.

BTW, What is the JDT project? Could you give me more explanation about
JTD usage? :)

-Edward

On 8/21/08, Chanwit Kaewkasi <chanwit@gmail.com> wrote:
> Hello,
>
> I'm looking at Hama today and to be honest, I want to rename some
> interface and classes.
> For example,
>
> - interface MatrixInterface
> I think it should be Matrix
>
> - class Matrix
> it should be MatrixImpl
>
> etc.
>
> As far as I know, one of the most elegant interface design is Eclipse
> JDT project. Should we look at its package and class structure to
> apply to ours?
>
> Regards,
>
> Chanwit
>


-- 
Best regards, Edward J. Yoon
edwardyoon@apache.org
http://blog.udanax.org

Mime
View raw message