incubator-graffito-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ruchi goel <Ruchi.G...@Sun.COM>
Subject Re: problem checking out graffito source
Date Wed, 14 Feb 2007 05:12:22 GMT
Christophe Lombart wrote:
> On 2/13/07, ruchi goel <Ruchi.Goel@sun.com> wrote:
>
>> The dependency jars are no more in the specified location as refererred
>> in project.xml .
>
> Which dependencies ? all ?

The following :
<dependencies>
        <dependency>
            <groupId>org.apache.jackrabbit</groupId>   
            <artifactId>jackrabbit-core</artifactId>
            <version>1.2.1</version>
        </dependency>
        <dependency>
            <!-- slf4j-log4j12 -->
            <groupId>org.slf4j</groupId>
            <artifactId>slf4j-log4j12</artifactId>
            <version>1.0</version>
            <url>http://www.slf4j.org/download.html</url>
            <!--
                SLF4J adapter for log4j.
                -->
                </dependency>       
        <dependency>
            <groupId>concurrent</groupId>
            <artifactId>concurrent</artifactId>
            <version>1.3.4</version>
        </dependency>
        <dependency>
            <groupId>junit</groupId>
            <artifactId>junit</artifactId>
            <version>3.8.1</version>
            <properties>
                <scope>test</scope>
            </properties>
        </dependency>
        <dependency>
            <groupId>commons-collections</groupId>
            <artifactId>commons-collections</artifactId>
            <version>3.1</version>
        </dependency>
        <dependency>
            <groupId>geronimo-spec</groupId>
            <artifactId>geronimo-spec-jta</artifactId>
            <version>1.0-M1</version>
        </dependency>
        <dependency>
            <groupId>jsr170</groupId>
            <artifactId>jcr</artifactId>
            <version>1.0</version>
            <url>http://jcp.org/en/jsr/detail?id=170</url>
        </dependency>
        <dependency>
            <groupId>log4j</groupId>
            <artifactId>log4j</artifactId>
            <version>1.2.8</version>
        </dependency>
        <dependency>
            <groupId>lucene</groupId>
            <artifactId>lucene</artifactId>
            <version>1.4.3</version>
        </dependency>
        <dependency>
            <groupId>xerces</groupId>
            <artifactId>xercesImpl</artifactId>
            <version>2.6.2</version>
        </dependency>
        <dependency>
            <groupId>xerces</groupId>
            <artifactId>xmlParserAPIs</artifactId>
            <version>2.0.2</version>
        </dependency>
        <dependency>
            <groupId>org.apache.derby</groupId>
            <artifactId>derby</artifactId>
            <version>10.1.1.0</version>
        </dependency>


        <dependency>
            <groupId>commons-beanutils</groupId>
            <typeId>jar</typeId>
            <artifactId>commons-beanutils</artifactId>
            <version>1.7.0</version>

        </dependency>

        <dependency>
            <groupId>commons-digester</groupId>
            <typeId>jar</typeId>
            <artifactId>commons-digester</artifactId>
            <version>1.7</version>

        </dependency>
        <dependency>
            <id>commons-logging</id>
            <version>1.0.2</version>
            <url>http://jakarta.apache.org/commons/logging.html</url>
        </dependency>
        <dependency>
            <groupId>commons-lang</groupId>
            <artifactId>commons-lang</artifactId>
            <version>2.1</version>
            <type>jar</type>
            <properties>
                <war.bundle>true</war.bundle>
            </properties>
        </dependency>
       
       <dependency>
                  <id>cglib</id>
              <version>${cglib.version}</version>
       </dependency>
       
    </dependencies>
>
>
>> grafito site has a link ? Another question is can this be compiled with
>> Jackrabbit 1.2
> not yet
Shouldn't be a problem , right since Jackrabbit1.2 is backward compatible.


Mime
View raw message