incubator-graffito-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Reddin <gred...@apache.org>
Subject Re: [PATCH] graffito-J2-2.0-dev svn HEAD deployment patches
Date Tue, 22 Nov 2005 03:29:50 GMT

On Nov 20, 2005, at 4:52 PM, Christophe Lombart wrote:

Thanks for the help.  I've been able to get it working.  Here's some  
newbie notes if anyone needs them.

> * The subproject "engine" doesn't compile because the constructor for
> SpringComponentManager in J2 head has been changed. This is not use
> with J2. It can be use only when Graffito is running outside J2.

I just changed the method to return null.  Seems like this could have  
some negative ramifications, but it's working so far.

> * The maven goal "allDeploy" deploy in the wrong folder. Maybe it is a
> invalid config on my machine.

I got the same thing.  I just move the 2 war files from $TOMCAT_HOME/ 
webapps/WEB-INF/deploy to $TOMCAT_HOME/webapps/jetspeed/WEB-INF/deploy

> * I think we have to change the jetspeed version reference (in
> etc/artifact-versions.ent). I set "2.0-dev" instead of "2.0-M3".

Did that.

Also removed the jetspeed-persistence dependency as someone noted,  
but it was in engine/project.xml not jetspeed-deploy/project.xml

>> - jetspeed2-deploy/src/assembly/jetspeed-spring.xml has been removed.

I had to copy back in the jetspeed-spring.xml from my jetspeed/trunk/ 
target/jetspeed/WEB-INF/assembly directory.

Now I will start to figure out the permissions stuff.

Thanks,
Greg


Mime
View raw message