incubator-graffito-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christophe Lombart <christophe.lomb...@gmail.com>
Subject Re: Graffito build for Jetspeed-2 M4-SNAPSHOT
Date Wed, 21 Sep 2005 14:14:08 GMT
Maybe it is a regression. Are you using the subproject
'jetspeed2-deploy' to deploy into J2 ? See in this subproject, there
are some xml file uses to deploy the application.

Let me know if you need help. I don't know if I can access to your
modifications somewhere.

Thanks, 
Christophe 



On 9/21/05, Randy Watler <watler@wispertel.net> wrote:
> Christophe,
> 
> Hmmm. Looks like I have a bug to track down. I added permissions using
> the browser portlet. They went into the DB correctly, but were not
> recognized correctly when I logged off as admin and logged in as
> user/user. Thanks for the info.
> 
> Randy
> 
> Christophe Lombart wrote:
> 
> >By default only admin user can do something in the Graffito portlets
> >(read, write, ...).
> >Others have not access to the Graffito content.
> >
> >There are 2 ways to add the /user/user or any kind of groups :
> >* from the Browser Porlter, select one folder, select the edit mode
> >and than select the permission/security tab page , in this tab page,
> >you can set the security. You can apply the security recursivly.
> >* OR review the default access control in the script
> >/components/src/sql/GraffitoServer/insert-j2-security.sql
> >
> >By default, this script contains : for all folders below /graffito,
> >the admin user has a full control. we can change it.
> >
> >Christophe
> >
> >
> >
> >On 9/21/05, Randy Watler <watler@wispertel.net> wrote:
> >
> >
> >>Guys,
> >>
> >>I have finally managed a few more cycles on this... the day job has been
> >>wrecking havoc on my OS time as of late.
> >>
> >>I have the graffito portlets running for the most part on M4 now for the
> >>admin user, but when I grant view permission to the "/user/user" user to
> >>the root folder and its subfolder/children using the graffito browser
> >>portlet, it does not seem to take. I have verified that the
> >>SECURITY_PERMISSION and PRINCIPAL_PERMISSION tables are populated correctly.
> >>
> >>Are the graffito permissions fully functional on M3, [I do not have a
> >>convenient M3 setup at the moment, so yes, I'm being lazy and asking
> >>here :-)]?
> >>
> >>Thanks,
> >>
> >>Randy
> >>
> >>
> >>
> >>
> >>
> >
> >
> >
> >
> 
> 
>

Mime
View raw message