incubator-graffito-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sandro Böhme <sandro.boe...@gmx.de>
Subject Re: [jira] Created: (GRFT-37) Final JCR Mapping Document PROPOSAL // mapping structure
Date Sun, 28 Aug 2005 20:31:50 GMT
Christophe Lombart wrote:

>2005/8/27, Sandro Böhme <sandro.boehme@gmx.de>:
>  
>
>>Oliver Kiessler wrote:
>>
>>    
>>
>>>>>Here is a simplification of the Sandro proposal....
>>>>>          
>>>>>
>>>>I'm more for a mapping file similar to this:
>>>>       <mapping>
>>>>           <classAttributes
>>>>packageName="org.apache.portals.graffito.jcr.testmodel"
>>>>className="CmsObject"/>
>>>>           <nodeTypeAttributes nodeTypeName="graffito:CmsObject">
>>>>               <supertype>nt:base</supertype>
>>>>           </nodeTypeAttributes>
>>>>           <subitemMapping propertyName="objectId" parameterType="long"
>>>>jcrPropertyDefinition name="graffito:parentId" />
>>>>      </mapping>
>>>>
>>>>
>>>>        
>>>>
>
>ahh ok for this one. I spoke the first mapping file (whith
>getter/setter). The first one was too verbose.
>  
>
One goal of my proposal is, to split the class descriptors 
(classAttributes) and the node type
descriptors (nodeTypeAttributes) of the mapping tag into two tags. This 
way the user knows
exactly if an xml-attribute belongs to a class or a node type. I also 
used the term "mapping"
for a tag because I think as we map in both directions it cannot be 
"class-mapping" or
"nodetype-mapping" or something similar.

>A couple of minors change I would like to add : 
>* group on the same attribute the pck name and the class name. Why are
>split them into 2 attributes ?
>  
>
+1 Whatever you prefer here.

>* Rename some tags to be more explicit for the end-user : 
>-ClassAttribute into classdescriptor or something like
>that."Attribute" is not really appropriate here.
>  
>
+1

>- subItemMapping into fielddescriptor or something like that. As
>  
>
+1

>explained in the proposal doc, we need to map simple fieds, bean
>fields and collection. So, we need to use different tags for that.
>  
>
Where do you see the difference between field and a bean-field?

>I have not yet thinking about the nt tags.
>
>Oho, I think both proposal becomes more and more similar. That's good :-)
>  
>
Absolutely. I would be glad if we find a mapping structure we are all 
happy with.

Regards,

Sandro

>
>  
>


Mime
View raw message