incubator-graffito-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christophe Lombart <christophe.lomb...@gmail.com>
Subject Re: Graffito + PostgreSQL
Date Mon, 22 Aug 2005 13:42:28 GMT
2005/8/20, Martin Koci <martin.koci@aura.cz>:
> Hi,
> I'm trying Graffito on PostgreSQL - it works, I found only two problems:
> 1) graffito-schema.xml contains:
> <table name="DOCUMENT_STREAM">
> <column name="DOCUMENT_STREAM_ID" primaryKey="true" required="true"
> type="INTEGER"/>
> <column name="CONTENT" type="BLOB"/>
> <column name="ISO_CODE" size="5" type="VARCHAR"/>
> <column name="ENCODING" size="30" type="VARCHAR"/>
> </table>
> 
> but after generating SQL create script generated graffito-schema.sql
> contains:
> 
> CREATE TABLE DOCUMENT_STREAM
> (
> DOCUMENT_STREAM_ID integer NOT NULL,
> -->> CONTENT, <<-- datatype is missing, it has to be 'bytea'
> ISO_CODE varchar (5),
> ENCODING varchar (30),
> PRIMARY KEY (DOCUMENT_STREAM_ID)
> );
> 
> maybe Torque/Maven plugin issue?

Thanks for the info, I'm going to check. It looks like a Torque issue. 

> 
> 2) Column ISO_CODE is defined twice in graffito-schema.xml - for table
> DOCUMENT_STREAM and for table CMS_OBJECT. But repository.xml contains no
> mapping for ISO_CODE on CMS_OBJECT.
> I think ISO_CODE should be defined only for DOCUMENT_STREAM because
> neither CmsObject.class nor it's children havent property 'isoCode',
> only DocumentStream.class has such property.
> 
> 

Oops, some code clean-up is required. Thanks again. I'm going to add
thoses issues in Jira. Feel free to use Jira to add more issues.

Christophe

Mime
View raw message