incubator-graffito-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raphaël Luta <raph...@apache.org>
Subject Running graffito in J2 HEAD
Date Thu, 21 Jul 2005 11:33:18 GMT
I'm trying to build and run Graffito with the latest Jetspeed SVN HEAD.

There are a couple of issues at deployment phase:
- the new j2 maven plugin does not behave exactly as the old jetspeed2 plugin
  and it looks for graffito components in the jetspeed2 maven repository
  directory.
- the spring files need to be synchronized (esp. the datastore source name
  seems to have changed from jetspeed to JetspeedDS)

And when all the above is actually done and deployed in J2, the portlets
themselves throw exceptions:

Graffito Content Browser (edit mode)  	
Portlet is Not Available: null
Reason: Failed to execute method :permission.retrieve

TreePortlet:
Failed to load portlet org.apache.portals.graffito.portlets.TreePortlet:
java.lang.NullPointerException

DocumentPortlet:
Failed to load portlet org.apache.portals.graffito.portlets.DocumentPortlet:
java.lang.NullPointerException

Looking into the database, I can see that the tables have been created correcly
but they have no content except for SYS_CMS_TABLES.

Is there a populate script that is actually supposed to run to populate the DB
during the deployment process ?

-- 
Raphaël Luta - raphael@apache.org
Apache Portals - Enterprise Portal in Java
http://portals.apache.org/

Mime
View raw message