incubator-giraph-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Avery Ching (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (GIRAPH-18) Refactor BspServiceWorker::loadVertices()
Date Wed, 31 Aug 2011 16:57:10 GMT

    [ https://issues.apache.org/jira/browse/GIRAPH-18?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13094686#comment-13094686
] 

Avery Ching commented on GIRAPH-18:
-----------------------------------

+1

Nice work refactoring, makes the code more readable.  Sorry it took me so long to review,
but it's tougher for me without my trusty reviewboard =).  I was able to pass the unittests
with your changes.

I also like your change to save some memory (every bit helps).  

Couple of style notes:

We have a CODE_CONVENTIONS file in the base path, probably this should be updated?  I'll file
a separate JIRA for this.

1.  Map<I,List<Long>> ->  Map<I, List<Long>>
2.  Current style is limitted to 80 chars per line (or should be).  Maybe this is unrealistic?
3.  Some 2 style indentation, i.e.

	while ((inputSplitPath = reserveInputSplit()) != null) {
          Map<I,List<Long>> maxIndexStatMap =


> Refactor BspServiceWorker::loadVertices()
> -----------------------------------------
>
>                 Key: GIRAPH-18
>                 URL: https://issues.apache.org/jira/browse/GIRAPH-18
>             Project: Giraph
>          Issue Type: Improvement
>            Reporter: Jakob Homan
>            Assignee: Jakob Homan
>         Attachments: GIRAPH-18.patch
>
>
> Currently BspServiceWorker::loadVertices() is more than 200 lines and convoluted. I found
it difficult to grok while debugging today.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message