incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Jumper <mike.jum...@guac-dev.org>
Subject Re: [VOTE] Release Apache Guacamole 0.9.10-incubating (RC2)
Date Sun, 18 Dec 2016 04:33:13 GMT
On Sat, Dec 17, 2016 at 8:14 PM, Justin Mclean <justin@classsoftware.com>
wrote:

> Hi,
>
> Sorry but it’s -1 binding as the server artefact is missing a DISCLAIMER
> and NOTICE file.
>
>
Fair enough. Looks like we need to update EXTRA_DIST in the top-level
Makefile.am.

Also some files (for instance [1][2]]) contain the text of the GPL license.
> GPL is Category X and is not allowed as a dependancy (unless it’s an
> optional component or build tools like autoconf in the sever artefact). I
> think this may be is OK as the software in question is dual license but if
> that is the case you should just include the text of the license you wish
> it to be licensed under no the text of both licenses. Can you please fix
> this in the next release.
>
>
Yes ... assuming we can legally strip out the GPL option of that license
without violating said license. I'm wary of modifying/removing license
terms of third-party software.

Do you know for sure that this is OK?

For the source artefacts I checked:
> - artefacts name includes incubating
> - hashes and signatures good
> - server source is missing DISCLAIMER
> - client and server LICENSE file good
> - server artefact is missing NOTICE file
> - No unexpected binary files in source release
> - All source files have ASF headers
> - Can compile client application
> - Unable to compile server application
>
> The convenience binary file LICENSE, NOTICE, DISCLAIMERS look good.
>
> When configuring the server I get this error:
> configure: error: "libpng is required for writing png messages"
>
> But I do have libpng installed:
> brew install libpng
> Warning: libpng-1.6.26 already installed
>
> Is OSX a supported platform?


We don't *not* support it ... but I don't have experience building on OSX
myself. It stands to reason that it should build, assuming the headers,
etc. can be found by configure.

It would be nice if the README had a bit more information on how to compile
> and what the dependancies are.


The README could certainly use some updating. The manual does:

http://guacamole.incubator.apache.org/doc/0.9.10-incubating/gug/installing-guacamole.html#required-dependencies


> For instance I think the instruction "Before compiling, you need to have
> compiled and installed libguac, the core Guacamole library” may possibly be
> misleading?
>

Yes, that's definitely out-of-date. The libguac portion used to be a
separate project.

So ... based on the above, the following specific issues were identified:

1) DISCLAIMER and NOTICE are missing from
guacamole-server-0.9.10-incubating.tar.gz
2) The guacamole-server README needs to be updated to match the current
build
3) The CDDL+GPL license text of bundled dependencies needs to be stripped
of GPL text (assuming this is legal)

Is the issue with DISCLAIMER and NOTICE the only issue you've found which
blocks this release?

Thanks,

- Mike

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message