incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anh Dinh <dinh...@comp.nus.edu.sg>
Subject Re: [VOTE] Release apache-singa-incubating-0.2.0
Date Sun, 10 Jan 2016 13:03:16 GMT
Thanks Justin for the detailed check,



> GPL licensed files includes:
> ./config/ltmain.sh
> ./config/ltversion.m4
> ./config/lt~obsolete.m4
> ./config/config.guess
> ./config/config.sub
> ./config/install-sh (?)
> ./Makefile.in (?) this also has a ASF header which seems odd
>
> While this seems to be a build tool [7] I’m not 100% sure if all files
> here are OK.
>

We understand that those buildtool files can be included, and have indeed
exclude them from RAT check (see rat-excludes)



> For LICENSE:
> - path to tinydir.h is incorrect
> - missing licence for ./include/singa/utils/cuda_utils.h
> - include/utils/common.h path is incorrect and the file most likely has an
> incorrect ASF header
> - missing license for (BSD licensed) ./tool/cpplint.py. Possibly
> tool/cppling.py should be tool/cpplint.py?
> - missing licence for (BSD license?) ./examples/rnnlm/create_data.cc
> - copyright for tinydir is incorrect should be "Cong Xu, Baudouin Feildel”
> - files in include/mshadow/* are missing Apache header so it’s unclear if
> they are Apache licensed or where they are from. I think this is sort of OK
> [3]
> - copyright "Copyright (c) 2014, 2015, The Regents of the University of
> California (Regents)” may be incorrect, you may want to double check years
>

Thanks for pointing these out, they are entirely valid. From the last
release, we have restructured the codebase but forgotten to update the
LICENSE file, which result in the invalid paths.

Files in include/mshadows/* are bundled from mshadow project (
https://github.com/dmlc/mshadow) and they carry Apache v2.0 license (
https://github.com/dmlc/mshadow/blob/master/LICENSE).

Other issues  are due to our oversight, we apologize and will rectify them.



Would also be nice to have compile instructions. On OS X configure fails
> for me with:
> configure: error: unable to find cblas_sgemm() function
>
> Assuming you run configure &&  make to compile and OS X is supported but
> it’s not 100% clear.
>

Please refer to the README.md file for the build instruction. There's the
solution to the error you encountered (due to the compiler not be able to
find OpenBLAS library) in the FAQ section in the file.

Regards,
Anh.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message