incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yakov Zhdanov <yzhda...@apache.org>
Subject Re: [VOTE] Apache Ignite 1.1.0 release (RC5)
Date Wed, 20 May 2015 14:06:34 GMT
Guys,

I have added a comment to https://issues.apache.org/jira/browse/IGNITE-927
(it will be fixed this way):

Module ssh depends on com.jcraft-jsch-0.1.50
Module tools depends on org.jodd-jodd-lagarto-3.4.8
That is why following license files present:

./modules/ssh/licenses/jcraft-revised-bsd.txt
./modules/tools/licenses/jodd-revised-bsd.txt

Module visor-console does not depends on jcraft, so, license file
./modules/visor-console/licenses/jcraft-revised-bsd.txt can be removed.

--Yakov

2015-05-20 13:55 GMT+03:00 Yakov Zhdanov <yzhdanov@apache.org>:

> Guys,
>
> LICENSE, NOTICE and DEPENDENCIES are added by maven parent pom which does
> not consider .txt files and thinks that they are absent. In my view maven
> should have fail in this case. Anyway, this will be fixed and new rc will
> be resubmitted to PPMC once again. Brane, given you are busy should we
> consider extending PPMC vote for 96 hours?
>
> Ticket for Justin's comment on licenses packaging -
> https://issues.apache.org/jira/browse/IGNITE-927 (will be addressed in
> the next release).
>
> As far as other issues, my comments are below
>
>  * The "official" source for "official convenience" binaries should be
>     the source package, not some tag in the repository. The source
>     package is what we release; not the repository contents. I'm sure I
>     mentioned that before.
>
> YZ: Agree, there is a JIRA ticket for this -
> https://issues.apache.org/jira/browse/IGNITE-618
>
>   * I agree with Justin about binary package placing and naming; you'll
>     recall that I was quite eloquent on that topic a while ago, without
>     much effect.
>
> YZ: Ticket has been filed and will be addressed in the next release
> (Justin, it also covers "apache" in artifact names) -
> https://issues.apache.org/jira/browse/IGNITE-926
>
>   * There are many, many HTML syntax errors in the javadocs.
>
> YZ: Far from being a serious issue. Javadocs can be built without errors
> and look good in browser. I think this can be addressed with low priority
> in the background.
>
>   * Once finally run, the node says "New version is available at
>     ignite.incubator.apache.org: 1.0.0". Surely that's a bug if I'm
>     running 1.1.0?
>
> YZ: Well, this is the simplest way to implement update checker. If site
> has different version it should be a newer one. Once this gets released,
> the website will be updated and message will not pop up in logs. So, would
> not touch it for now.
>
> Thanks!
>
> --Yakov
>
> 2015-05-20 4:09 GMT+03:00 Branko ─îibej <brane@apache.org>:
>
>> On 20.05.2015 00:44, Justin Mclean wrote:
>> > Hi,
>> >
>> > +0 (binding) from me until these 2 issues are resolved. Of course other
>> IPMC members may vote differently.
>> >
>> > Several bundled files have GPL license headers e.g.
>> ./ipc/shmem/config.guess, ./ipc/shmem/ltmain.sh etc. While these look like
>> auto generated build files but I'm not sure that they can be included in a
>> source release.
>>
>> There's no way around including such files; any normal (i.e., not Java
>> :) source package that uses configure and libtool needs those files
>> bundled in the source.
>>
>> However, I'll have to vote -1: the LICENSE, NOTICE and DEPENDENCIES
>> files shouldn't be in the package. They appear to be some maven side
>> effect. Especially LICENSE and NOTICE are confusing because a user has
>> no way to be sure which file she should be reading.
>>
>> Other issues:
>>
>>   * The "official" source for "official convenience" binaries should be
>>     the source package, not some tag in the repository. The source
>>     package is what we release; not the repository contents. I'm sure I
>>     mentioned that before.
>>   * I agree with Justin about binary package placing and naming; you'll
>>     recall that I was quite eloquent on that topic a while ago, without
>>     much effect.
>>   * There are many, many HTML syntax errors in the javadocs.
>>   * Once finally run, the node says "New version is available at
>>     ignite.incubator.apache.org: 1.0.0". Surely that's a bug if I'm
>>     running 1.1.0?
>>
>> Finally, I apologize for not bringing these issues up on the PPMC vote
>> thread; I was sidetracked by other issues the last couple weeks.
>>
>> -- Brane
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
>> For additional commands, e-mail: general-help@incubator.apache.org
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message