incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ufuk Celebi <...@apache.org>
Subject [RESULT] [VOTE] Release Apache Flink 0.6.1-incubating
Date Wed, 24 Sep 2014 14:33:42 GMT
Thanks for taking the time to review and vote on this release. The vote passes with 3 binding
+1s and no -1s.

The binding +1s were from:
Henry Saputra
Alan Gates
Justin Mclean

We'll now move the artifacts to Apache mirrors.

Thanks,

The Apache Flink Team

On 22 Sep 2014, at 05:58, Justin Mclean <justin@classsoftware.com> wrote:

> Hi,
> 
> +1 binding
> 
> Here's what I checked
> - Vote good
> - artefact has incubating in name
> - MD5 and signatures correct
> - has DISCLAIMER
> - NOTICE and LICENSE good with a couple of minor issues (see below)
> - All source files have correct headers
> - No unexpected binary files in source package
> - can compile from source package
> 
> Some minor things perhaps you can look at fixing in next release.
> - "depends on and/or bundles" make it hard to review and what you need to add to license
depends on it it bundled or not. Any chance you could just list the MIT/BSD bundled bits in
LICENSE. I assume this was done so that you didn't need separate LICENSE/NOTICE files for
the source and binary releases?
> - Specify version of bootstrap used. From a quick glance look like you have multiple
versions ie 3.1.0 and 3.1.1. As bootstrap changed license around this time it would useful
to list the version number.
> - Looks like you may have multiple versions of jQuery as well eg (flink-0.6.1-incubating/flink-runtime/resources/web-docs-infoserver/js/jquery-1.10.2.js
and flink-0.6.1-incubating/flink-clients/resources/web-docs/js/jquery-2.1.0.js). These versions
are not mentioned in LICENSE.
> - May be missing a licence for normalise.css (see comment in /flink-0.6.1-incubating/flink-clients/resources/web-docs/css/bootstrap.css).
Not sure what's required here.
> - May be misisng a licence for sizzle.js (see comment at head of flink-0.6.1-incubating/flink-runtime/resources/web-docs-infoserver/js/jquery.js
> ). Not sure what's required here.
> - May not need flink-0.6.1-incubating/flink-clients/resources/web-docs/img/StratosphereLogo.png?
Or should that be changed to be a Flink logo?
> 
> Thanks,
> Justin
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
> For additional commands, e-mail: general-help@incubator.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message