incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko Čibej <br...@apache.org>
Subject Re: Incubator voting status page
Date Sat, 02 Feb 2013 09:46:54 GMT
On 01.02.2013 20:48, sebb wrote:
> On 1 February 2013 16:29, Branko Čibej <brane@apache.org> wrote:
>> On 01.02.2013 17:01, sebb wrote:
>>> On 1 February 2013 10:29, Branko Čibej <brane@apache.org> wrote:
>>>> On 31.01.2013 17:18, Branko Čibej wrote:
>>>>> On 31.01.2013 16:51, Daniel Shahaf wrote:
>>>>>> Branko Čibej wrote on Thu, Jan 31, 2013 at 16:40:14 +0100:
>>>>>>> I guess it's best if I ping infra and ask about getting this
done (or
>>>>>>> probably file an INFRA ticket). Infra are also in the best position
to
>>>>>>> know if we can have the page regenerated more often, e.g., once
an hour.
>>>>>> The first issue I see is that your script assumes it has local access
to
>>>>>> the public-arch tree, so it can only run on minotaur (or on the
>>>>>> mail-archives.a.o box).
>>>>> Ah, that's a good enough point for doing the dynamic-include thing.
>>>>> Initially I thought I'd be downloading the mboxes from mail-archives,
>>>>> but ... local access is soo much faster and easier.
>>>>>
>>>>> I'll make it work as Christian suggested then.
>>>> And it's done. An embedded status page is created on minotaur and
>>>> dynamically embedded into the new vote status page. There are only two
>>>> issues:
>>>>
>>>>   * It'll take a while for this to show up, since the incubator site
>>>>     refreshes once a day (?); in the meantime, the embedded status link
>>>>     will be dead.
>>> It updates immediately, provided that you publish any changes.
>>>
>>>>   * The embedded content gets loaded from people.apache.org, not
>>>>     incubator.apache.org; AIUI that'll cause browsers to portend
>>>>     disaster and in some cases refuse to load the vote status. This
>>>>     should be fixed, suggestions welcome.
>>> The use of target=_blank causes a new window to created each time the
>>> link is clicked; that seems wrong.
>> Yes, I just noticed that; copy-paste bug from the standalone page link,
>> will fix.
>>
>>> Also, it does not work in Firefox. Or Chrome. Or Opera. Or IE.
>> That's caused by the the access control constraints, as I point out in
>> the text you quoted. I tried circumventing that in .htaccess, but the
>> incubator site config doesn't load mod_headers, so that won't help.
> However, in that case surely it ought to display an error message?
>
> There is some code that looks as though it tries to report the error:
>
> if (fragment_loader.status != 200)
>     html = "<p>Content is not available</p>";
> else {
>     container = document.getElementById("voter").parentNode;
>     container.innerHTML = fragment_loader.responseText;
> }
>
> That looks wrong - why is the error written to a different variable?

Meh, another bug. Thanks for catching it and fixing it.

(Apparently I'm not at my best these days ... only this morning I
started wondering why that error message wasn't showing up. Sigh.)

-- Brane


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message