incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gavin McDonald" <ga...@16degrees.com.au>
Subject RE: nbsp in unicode podling pages
Date Mon, 15 Aug 2011 07:28:04 GMT


> -----Original Message-----
> From: Dennis E. Hamilton [mailto:dennis.hamilton@acm.org]
> Sent: Monday, 15 August 2011 4:02 PM
> To: general@incubator.apache.org
> Subject: RE: nbsp in unicode podling pages
> 
> Looking at the source of the text/html at
> <http://incubator.apache.org/tashi/>
> 
> it appears that this is relevant:
> 
> <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-
> 1"/>
> 
> in the <head> element.  Unfortunately, the pages are served up as UTF8.  If I
> change the encoding in which the page is viewed to 8859-1, the problem
> goes away.
> 
> It could be because all of the CSS is in front of the <head> element.
> 
> It also could be because the server reports a MIME Type that has UTF-8
> coding as its charset parameter and the file is not in UTF-8.
> 
> Finally, did the XML have &nbsp; or &0xa0; ?  And what is the explicit
> character-set encoding specified in the XML prolog?  (Oddly, the default for
> MIME Type text/xml is not a Unicode encoding.)

Hi Dennis,

You'll find the XML source for that page here:

http://svn.apache.org/repos/asf/incubator/tashi/site/xdocs/index.xml

which is missing the navigation applied later, I see that

http://svn.apache.org/repos/asf/incubator/tashi/site/xdocs/stylesheets/site.vsl

has a line :

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>

The menu items in question are here:

http://svn.apache.org/repos/asf/incubator/tashi/site/xdocs/stylesheets/project.xml

and the source uses  &#160;

the transformed output html of that source xml file is

http://svn.apache.org/repos/asf/incubator/tashi/site/docs/index.html

and looks like the spaces are ok at that point.

appropriate charsets and mime types seem to be set ok in the web server conf files.

HTH

Gav...

> 
> There's a long chain of transformation/character-set-encoding-assumption
> points at which this could be going wrong in the web-site-production tool
> chain.
> 
>  - Dennis
> 
> -----Original Message-----
> From: Michael Stroucken [mailto:mxs+apache@cmu.edu]
> Sent: Sunday, August 14, 2011 21:32
> To: general@incubator.apache.org
> Subject: nbsp in unicode podling pages
> 
> Hi,
> 
> I'm noticing that non-breaking spaces are written out as chr(0xa0) in the
> HTML documents after being converted from XML.
> (http://incubator.apache.org/tashi/). To work properly, the spaces should be
> encoded something like chr(0xc0)+chr(0xa0), or &nbsp; I guess.
> 
> Am I missing some configuration in the site building setup?
> 
> The locale I am running ant in is "de_DE.UTF-8".
> 
> Thanks for any help,
> Michael.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
> For additional commands, e-mail: general-help@incubator.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
> For additional commands, e-mail: general-help@incubator.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message