incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edward J. Yoon" <edwardy...@apache.org>
Subject Re: [VOTE] Release Hama version 0.2-incubating (second)
Date Mon, 11 Apr 2011 06:23:53 GMT
Hello,

Thanks for your review.

BTW, if HAMA-374 is done, we can remove all libraries (including
GroboUtils) and ant-build&nightly-build scripts at once. It's
scheduled to version 0.3.

Since many improvements and new features are planned in next 0.3
version and few patches are already submitted
(http://s.apache.org/G8n), we'd like to release this '0.2-incubating
candidate' as soon as possible.

Thanks.

On Mon, Apr 11, 2011 at 9:58 AM, sebb <sebbaz@gmail.com> wrote:
> On 8 April 2011 06:42, Edward J. Yoon <edwardyoon@apache.org> wrote:
>> Hi IPMCers and Incubator community,
>>
>> The previous mentioned problems (e.g., license, notice, disclaimer,
>> and website logo/text) are all fixed and I just created RC3. There'are
>> only changes of text, no changes at the code level.
>>
>> Hama Website:
>> http://incubator.apache.org/hama
>>
>> The release artifact, sums, GPG key and signature:
>> http://people.apache.org/~edwardyoon/dist/0.2.0-RC3/
>>
>> Subversion tag for release:
>> https://svn.apache.org/repos/asf/incubator/hama/tags/0.2-RC3/
>
> The project appears to be using Maven to build, and declares
> dependencies to various libraries.
>
> So why are the libraries included in SVN in the lib directory?
>
> This does not make sense - apart perhaps from grobo-testing-junit
> which does not appear to have been uploaded to Maven Central yet.
> But even that is available from at least one Maven repo, e.g.
> https://m2.duraspace.org/content/repositories/public/org/fcrepo/GroboTestingJUnit-core/.
>
> I just tried "mvn test" against the SVN tag, having removed all but
> Grobo from the lib directory, and it compiled and ran fine.
> Seems unnecessary and wasteful to store duplicates of the libraries in
> SVN and to include them in the archive.
>
> By the way, commons-httpclient 3.0.1 is very out of date, the latest
> 3.x release is 3.1 (which itself is now superseded by the 4.x series),
> likewise commons-logging is now at 1.1.1, and you don't normally need
> both commons-logging and commons-loggin-api
>
> JUnit 3.8.1 is also obsolete; for Java 1.6 (which the POM targets) I
> would expect to see v4.8.2
>
>> Please vote again on this thread!
>>
>> [ ] +1 Release the packages as Apache Hama 0.2-incubating
>> [ ] -1 Do not release the packages because...
>>
>> Thanks in advance!!
>>
>> --
>> Best Regards, Edward J. Yoon
>> http://blog.udanax.org
>> http://twitter.com/eddieyoon
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
>> For additional commands, e-mail: general-help@incubator.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
> For additional commands, e-mail: general-help@incubator.apache.org
>
>



-- 
Best Regards, Edward J. Yoon
http://blog.udanax.org
http://twitter.com/eddieyoon

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message