incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <dava...@gmail.com>
Subject Re: [PROPOSAL][VOTE] Subversion
Date Wed, 11 Nov 2009 22:35:14 GMT
Dan,

"It's up to each project to get their releases correct" - Yes. But not everyone hangs out
on the dev@maven or 
general@incubator. Hence the request to broadcast.

I really don't understand the "why?" - No one is trying to mandate using a specific pom across
all PMC(s). Just the fact 
that there was a problem that was actively worked on and fixed and the proposed solution.
Basically telling pmcs take it 
or leave it. At the very least pay attention that the jars that they release should be build-able
using the source zip(s).

-- dims

On 11/11/2009 05:22 PM, Daniel Kulp wrote:
> On Wed November 11 2009 4:52:23 pm Davanum Srinivas wrote:
>> Brian,
>>
>> Do you mind sending an email to pmcs AT apache.org to inform them that they
>>   should be using this new version of Apache pom? And any other additional
>>   instructions needed to enable this "feature" to work.
>
> Why?   It's up to each project to get their releases correct.   That version
> of the Apache pom isn't required to get the needed "source" bundles created.
> I know for CXF, the current parent poms don't work at all and thus we
> SHOULDN'T use it.
>
> Dan
>
>
>
>>
>> thanks,
>> dims
>>
>> On 11/11/2009 03:51 PM, Brian Fox wrote:
>>>> What is happening in some Java projects, via Maven's release plugin,
>>>> is disturbing since the "source release" only exist in the subversion
>>>> repository
>>>
>>> This problem has been solved and is no longer valid. Any
>>> repetition of the old news is total fud. We have for many months now
>>> been providing proper source releases for EVERYTHING in the maven
>>> project and just recently promoted the same to the Apache pom making
>>> it automatic for any Apache project with the new pom. See links below
>>> for more info:
>>>
>>> http://old.nabble.com/Update-on-ASF-Release-requirements-ts23379350.html#
>>> a23379350
>>> http://old.nabble.com/-VOTE--Apache-%28parent-POM%29-version-7-ts26221188
>>> .html
>>>
>>>
>>> As far as I understand the requirements, this issue is completely
>>> resolved so lets stop saying that Maven produces incorrect releases.
>>> It was never an issue with the tool itself, but as a project we've
>>> fixed it and are sharing it to all projects at Apache using Maven.
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
>>> For additional commands, e-mail: general-help@incubator.apache.org
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
>> For additional commands, e-mail: general-help@incubator.apache.org
>>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message