incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Burilo <igor.bur...@polarion.org>
Subject Re: [PROPOSAL][VOTE] Subversion
Date Mon, 09 Nov 2009 17:01:24 GMT

> We have a number of *user-configurable* dependencies which are not
>compatible with the AL:
> - Neon, a HTTP client library, used by libsvn_ra_neon, is LGPL.
>   (An alternative HTTP client library, libsvn_ra_serf uses the Serf
>    library under ALv2.)

Neon is currently Subversion's default RA DAV layer.
But Neon's license (LGPL) isn't compatible with Apache License and as Neon
is optional, will Serf library become a default one?
>From the other side, Serf library is considered as experimental, "though it
appears to work in the common cases quite well".

Thanks, Igor
-- 
View this message in context: http://old.nabble.com/-PROPOSAL--VOTE--Subversion-tp26203843p26269837.html
Sent from the Apache Incubator - General mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message