incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: Publishing site
Date Thu, 30 Apr 2009 19:33:27 GMT
On 30/04/2009, sebb <sebbaz@gmail.com> wrote:
> On 30/04/2009, Robert Burrell Donkin <robertburrelldonkin@gmail.com> wrote:
>  > On Thu, Apr 30, 2009 at 1:46 PM, sebb <sebbaz@gmail.com> wrote:
>  >  > On 30/04/2009, Robert Burrell Donkin <robertburrelldonkin@gmail.com>
wrote:
>  >  >> On Thu, Apr 30, 2009 at 12:10 PM, sebb <sebbaz@gmail.com> wrote:
>  >  >>  > On 30/04/2009, Robert Burrell Donkin <robertburrelldonkin@gmail.com>
wrote:
>  >  >>  >> On Tue, Apr 28, 2009 at 2:35 AM, sebb <sebbaz@gmail.com>
wrote:
>  >  >>  >>  > On 28/04/2009, Gavin <gavin@16degrees.com.au> wrote:
>  >  >>  >>  >> Hi All,
>  >  >>  >>  >>
>  >  >>  >>  >>  I checked out Incubator site.
>  >  >>  >>  >>  Before doing any changes at all I thought I'd build
the site and see if all
>  >  >>  >>  >>  is well.
>  >  >>  >>
>  >  >>  >>
>  >  >>  >> so did i
>  >  >>  >>
>  >  >>  >>
>  >  >>  >>  >>  So, whats the deal with all those changes?
>  >  >>  >>  >
>  >  >>  >>  > Just checking - are these "real" changes, or just whitespace
or EOL changes?
>  >  >>  >>
>  >  >>  >>
>  >  >>  >> i find a lot of charset related changes. i think this must
be related
>  >  >>  >
>  >  >>  > Any examples?
>  >  >>
>  >  >>
>  >  >> what sort of thing did you have in mind?
>  >  >
>  >  > One or two short diffs.
>  >
>  >
>  > --- site-publish/projects/sling.html    (revision 770200)
>  >  +++ site-publish/projects/sling.html    (working copy)
>  >  @@ -209,7 +209,7 @@
>  >          </tr>
>  >          <tr>
>  >            <td>Committers</td>
>  >  -          <td>��</td>
>  >  +          <td>??</td>
>
>
> Neither of those looks correct...
>
>  I suspect it should probably be <td>&nbsp;</td> to ensure that empty
>  cell displays correctly.

The original XML has <td>&#160;</td> which is NBSP in UTF-8.

[BTW, this works fine for me when building on Windows/XP with Java 1.4
- I just see a space.]

It would be better if the html used &nbsp; as well.
However this appears to be rather difficult to do when using XML with Anakia.

>
>  >            <td>See up to date list on the <a
>  >  href="http://incubator.apache.org/sling/site/project-team.html">Sling
>  >  website</a></td>
>  >          </tr>
>  >        </table>
>  >
>  >
>  >  >>  >>  to the upgrade to anakia and the change to UTF-8. i'm on linux.
>  >  >>  >>
>  >  >>  >>  any ideas?
>  >  >>  >
>  >  >>  > I've not seen that with Apache site.
>  >  >>  >
>  >  >>  > Just wondering if it might be related to svn:mime-type ?
>  >  >>  > Does SVN correctly handle charsets if the mime-type is not set
up?
>  >  >>
>  >  >>
>  >  >> sometimes
>  >  >>
>  >  >>  setting "svn propedit svn:mime-type" to "text/html; charset=UTF-8"
>  >  >>  doesn't make any different to the diff for me
>  >  >
>  >  > Might need to do the same for the XML?
>  >
>  >
>  > didn't make much difference either
>  >
>  >
>  >  - robert
>  >
>  >  ---------------------------------------------------------------------
>  >  To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
>  >  For additional commands, e-mail: general-help@incubator.apache.org
>  >
>  >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message