incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Fischer <>
Subject Re: [VOTE]apache-empire-db-2.0.4-incubatingandapache-empire-struts2-ext-1.0.4-incubatingrelease
Date Mon, 22 Sep 2008 17:28:28 GMT
On Mon, 22 Sep 2008, sebb wrote:

> On 22/09/2008, Thomas Fischer <> wrote:
>>>>  I'd reckon that we all now agree that the tomcat jars can be included.
>>> Assuming that they have not included the jars incorrectly.
>>  I will check that the jars in question are those released by tomcat.
>>> Perhaps it would be better to double-check with legal?
>>  If the jars are ASL licensed, I do not see the need. Correct me if I'm
>> wrong.
> What I meant was - just because the jars are part of another Apache
> product does not necessarily mean that they are ASL licensed. One
> would hope that they are, but given some of the other postings in this
> thread I though it would be prudent to double-check this.
> I just checked the jsp-api and servlet-api jars from Tomcat 5.5.27 and
> 6.0.18; unfortunately the jars themselves do not contain NOTICE or
> LICENSE files, and the jar manifests are no help either - it's not
> clear where the jars originated.
> However, looking at the source archives for Tomcat, one can see that
> the sources for the two jars are present, so it looks like the jars
> are indeed created from Tomcat sources, not copies of the Sun jars. I
> looked a a few of the source files, and these have standard AL2.0
> headers. So it looks OK to use the jars from Tomcat, as they don't
> appear to be the Sun jars.
> It's a pity that the Tomcat jars don't contain proper manifests + N &
> L files; I'll see about raising that with the Tomcat developers.

Thanks for checking. I was assuming that the tomcat people know what they 
are doing.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message