incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henning Schmiedehausen <henn...@apache.org>
Subject Re: [VOTE]apache-empire-db-2.0.4-incubatingandapache-empire-struts2-ext-1.0.4-incubatingrelease
Date Fri, 19 Sep 2008 07:27:13 GMT
Uh, what? AFAIK they are under AL 2.0. It would be absurd if we could
not distribute jars taken from other Apache releases. Can you point me
at the vote thread with the rejection?

	Ciao
		Henning

On Fri, 2008-09-19 at 09:13 +0200, Rainer Döbele wrote:
> Hi Henning,
> 
> In fact the jars we had in our struts2-ext 1.0.3 release candidate were taken from Tomcat
5.5. The manifest says:
> 
> 	Manifest-Version: 1.0
> 	Ant-Version: Apache Ant 1.6.5
> 	Created-By: 1.4.2_11-b06 (Sun Microsystems Inc.)
> 
> 	Name: javax/servlet/
> 	Specification-Title: Java API for Servlets
> 	Specification-Version: 2.4
> 	Specification-Vendor: Sun Microsystems, Inc.
> 	Implementation-Title: javax.servlet
> 	Implementation-Version: 2.4.public_draft
> 	Implementation-Vendor: Apache Software Foundation
> 
> Thomas investigated this and said it was not permitted to distribute those. This was
the main reason why he rejected the release.
> Martijn agreed with that too.
> 
> @Thomas: since Tomcat is distributing them, why can't we?
> 
> Rainer
> 
> > -----Ursprüngliche Nachricht-----
> > Von: Henning Schmiedehausen [mailto:henning@apache.org]
> > Gesendet: Donnerstag, 18. September 2008 19:48
> > An: Rainer Döbele
> > Cc: general@incubator.apache.org; empire-db-dev@incubator.apache.org
> > Betreff: Re: [VOTE]apache-empire-db-2.0.4-incubatingandapache-empire-
> > struts2-ext-1.0.4-incubatingrelease
> > 
> > On Thu, 2008-09-18 at 11:00 +0200, Rainer Döbele wrote:
> > 
> > > Does anyone know where to obtain distributable versions of the servlet-
> > api.jar and jsp-api.jar from? The only implementations I know come from
> > Sun Microsystems and are under CDDL License.
> > 
> > Tomcat is shipping implementations, so there are Apache licensed ones /
> > compatible licensed ones. Just grab them from e.g. Tomcat 5.5
> > 
> > 	Ciao
> > 		Henning
> > 
> > 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message