incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Craig L Russell <Craig.Russ...@Sun.COM>
Subject Re: SVN move
Date Mon, 28 Jul 2008 17:33:56 GMT
Hi Roland,

On Jul 28, 2008, at 12:49 AM, Roland Weber wrote:

> Hi Craig,
>
> Craig L Russell wrote:
>> [craig] I think I got the attribution correct in this. Please  
>> correct if I got it wrong.
>
> You got it right (I think :-).

Whew!
>
>
>>> [roland]Yes, and why shouldn't it be? Anybody can pull Apache  
>>> sources from
>>> our public SVN repo and make releases with or without modifications
>>> under any license that is compatible with the AL 2.0.
>> [craig]This is a misunderstanding. The Apache license is very  
>> liberal. You can do pretty much anything you like with stuff you  
>> pull from the Apache site *except* call it an Apache release or  
>> remove notices.
>
> IIRC, the AL has a patent termination clause. The AL requires that
> the documentation of the redistributen says "contains software
> developed by the ASF" (that's not the exact wording here). If sb
> wants to redistribute AL code under a license that does not honor
> the patent termination clause, or that negates the ASF attribution
> requirement, there is a problem.

You have lost me here. Are you saying that the supposed license  
contradicts the patent grants in the Apache license, which are  
explicitly mentioned by the required notices?

Has this ever happened, or are we in hypothetical-land?

> That's what I am referring to with
> "compatible license". "Pretty much anything" means "not everything",
> and "compatible" means that you don't leave the "pretty much" area.
>
>
>>>> [alan]What if the license for those releases was incompatible w/  
>>>> AL2.0?
>>>
>>> [roland]That would be a show stopper.
>> [craig]No, it's not a showstopper.
>
> You noticed the "incompatible" in the question?
> Not "different", but "incompatible".

As long as you preserve the notices in the AL2.0, you can relicense  
stuff you get from Apache releases. So we don't focus on the term  
"incompatible" with regard to stuff leaving Apache, but with stuff  
entering Apache.

Maybe you can give an example of a license that is incompatible with  
AL2.0 in the context of a downstream user/distributor of Apache stuff?

Craig

>
>
> cheers,
>  Roland
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
> For additional commands, e-mail: general-help@incubator.apache.org
>

Craig L Russell
Architect, Sun Java Enterprise System http://java.sun.com/products/jdo
408 276-5638 mailto:Craig.Russell@sun.com
P.S. A good JDO? O, Gasp!


Mime
View raw message