incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brett Porter" <>
Subject Re: maven repository
Date Sat, 31 May 2008 02:53:39 GMT
2008/5/31 Noel J. Bergman <>:
>> I'm more than happy to throw an enforcer rule into the next Maven
>> release that warns users if they are:
>> - using the incubator repository
>> - using an artifact from org.apache.* with version *-incubating.
>>   and point them to a URL to learn more.
>> Will that do?
> Wearing my Incubator PMC hat?  Possibly.  Please elaborate.

I'd need to look into it (Brian wrote the enforcer so might offer his
thoughts), but I think we can add a rule that will fail at the start
of a build using such artifact(s). It can also display a message for
how to configure the project such that it will disable the message and
failure. It's per project, not per user. It's not transitive, so any
project that uses something that uses an incubating artifact would
need to do the same.

> Obviously, this won't solve the problem of people using older versions of
> Maven, but I'm not sure if there is a good solution to that, is there?

Not really.

- Brett

Brett Porter

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message