incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Riley" <ri...@diplomats.com>
Subject Implicit SSL
Date Mon, 05 Mar 2007 12:33:48 GMT
Hi,
I read in the documentation that this FTP server supports implicit SSL
connections. However, when I dowload the snapshot the configuration files
does not look the same as in the configuration. Does it still support
implicit SSL?

I tried to setup explicit SSL with the test keystore but I didn't get it
to work either. My clients tell me that negotiation failed with 431
Service is unavailable

Configuration:
config.socket-factory.class=org.apache.ftpserver.socketfactory.SSLFtpSocketFactory
config.socket-factory.address=localhost
config.socket-factory.port=21
config.socket-factory.ssl.keystore-file=./res/.keystore
config.socket-factory.ssl.keystore-password=password
config.socket-factory.ssl.keystore-type=JKS
config.socket-factory.ssl.keystore-algorithm=SunX509
config.socket-factory.ssl.ssl-protocol=TLS
config.socket-factory.ssl.client-authentication=false
config.socket-factory.ssl.key-password=password

So my next step was to run the SSL tests using:
mvn -Pssl-tests test
This one however can't run since it has a dependency problem:
[INFO] Using default encoding to copy filtered resources.
Downloading:
http://people.apache.org/repo/m2-snapshot-repository/commons-net/commons-net/2.0.0-SNAPSHOT/common
s-net-2.0.0-SNAPSHOT.jar
[WARNING] Unable to get resource from repository apache.snapshots
(http://people.apache.org/repo/m2-snapshot-re
pository)

Does the SSL support work or am I just doing something terrible wrong?

Except for the SSL support everything works just fine.

Best Regards

John Riley

Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message