incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yoav Shapira" <yo...@apache.org>
Subject Re: errors updating site
Date Mon, 13 Nov 2006 18:42:10 GMT
Hi,

On 11/13/06, Martin Sebor <sebor@roguewave.com> wrote:
> First, I get the error below (and seems to either hang or
> spin indefinetly after that.) Is gcc required in order to
> run ant?

gcc is not required and not used.  gcj is GNU Classpath Java, an
alternative Java binary that comes bundled with some linux
distributions as their default.  Where are you running this ant
command?

When I run "java -version" on people.apache.org, it doesn't try to
invoke gcj, but instead give me Sun JDK 1.5.0_08, which is cool.  And
ant works fine as well.

> Second, after setting up gcc/gcj and rerunning ant, I get the
> attached output. Is the exception trace normal? if not, what
> does it mean and how do I get around it?

Assuming you're talking about the antlr exception, no, it's not
normal.  I haven't seen it before when updating the Incubator site
myself, anyways.  It looks like there's a version incompatibility
between the (first) antlr on your runtime classpath and the one
expected by the Incubator site build.xml.

Yoav

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message