incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Sebor <>
Subject Re: errors updating site
Date Tue, 14 Nov 2006 00:15:59 GMT
Yoav Shapira wrote:
> Hi,
> On 11/13/06, Martin Sebor <> wrote:
>> First, I get the error below (and seems to either hang or
>> spin indefinetly after that.) Is gcc required in order to
>> run ant?
> gcc is not required and not used.  gcj is GNU Classpath Java, an
> alternative Java binary that comes bundled with some linux
> distributions as their default.  Where are you running this ant
> command?

I checked out incubator/public/trunk/ on my local server and
ran ant in the "trunk" directory as recommended on the Web

> When I run "java -version" on, it doesn't try to
> invoke gcj, but instead give me Sun JDK 1.5.0_08, which is cool.  And
> ant works fine as well.

Here's what I get when I run the command on my server:
$ java -version
java version "1.5.0_07"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_07-b03)
Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_07-b03, mixed mode)

>> Second, after setting up gcc/gcj and rerunning ant, I get the
>> attached output. Is the exception trace normal? if not, what
>> does it mean and how do I get around it?
> Assuming you're talking about the antlr exception, no, it's not
> normal.  I haven't seen it before when updating the Incubator site
> myself, anyways.  It looks like there's a version incompatibility
> between the (first) antlr on your runtime classpath and the one
> expected by the Incubator site build.xml.

The exception went away after I set up the JDK. But the html
file still hasn't been updated. All I get is the output below.
Is there something else I'm missing?

$ ant
Buildfile: build.xml



    [anakia] Transforming into: /build/sebor/incubator/site-publish

Total time: 2 seconds


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message