incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: [web site] link to anchor within same page not working
Date Fri, 10 Feb 2006 03:03:51 GMT
Jean T. Anderson wrote:
> I added a table of contents to
> http://incubator.apache.org/incubation/Incubation_Policy.html, but the
> links to anchors within the same page don't work.  Same problem occurs
> in another page: the last sentence of
> http://incubator.apache.org/howtoparticipate.html also has a link to an
> anchor in the same file that also doesn't work -- look at the link for
> "Project Website Howto".
> 
> I compared site-author/incubation/Incubation_Policy.xml to
> xdocs/dev/committers.xml, and don't spot the problem in the source xml.
> 
> I compared the site.vsl files and the incubator site has a "base"
> setting that the dev site does not:
> 
> <base href="http://incubator.apache.org/" />
> 
> I removed that setting and links to anchors in the same page now work --
> at least locally. But it regenerates every page on the site, so I
> hesitate to commit.
> 
> What am I likely to break on the incubator site by removing that "base"
> setting? Does anyone know a better way to fix this?

Nothing will be broken. Leo added that recently to assist
with viewing the built pages locally. So it is safe to
remove it.

svn log site-author/stylesheets/site.vsl
"
r374994 | leosimons | 2006-02-05 21:13:06 +1100 (Sun, 05 Feb 2006) | 1 line

Since the anakia template does not have the 'relativise' functionality
enabled, put in place a <base> tag -- this makes it easier to review
changes on your local machine.
"

-David

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message