incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Crossley <cross...@apache.org>
Subject Re: Incubator site status wrt a move to Anakia?
Date Sat, 28 Jan 2006 04:20:55 GMT
Jean T. Anderson wrote:
> David Crossley wrote:
> >Jean T. Anderson wrote: 
> >>David Crossley wrote:
> >>...
> >>The links on the left aren't working. Every link I click on comes up 
> >>"file not found". I checked the generated index.html and files are set 
> >>to root instead of relative to local; for example, this:
> >>
> >>  <li><a href="/index.html">Home</a></li>
> >>
> >>needs to be ...
> >>
> >>  <li><a href="./index.html">Home</a></li>
> >
> >Yeah, i don't understand how the linking operates.
> >That is why i said in another thread that i cannot
> >demo at my people.a.o space anymore. The docs2/* will
> >function properly when it is placed at incubator.a.o
> >
> >We get the same situation when generating the
> >infrastructure/site for e.g. a.o/dev/
> >
> >After generating it, cannot use local links
> >and so need to browser to specific pages, e.g.
> >file:///svn/asf/incubator/site/docs2/faq.html
> 
> oh! ok, thanks. I won't beat a dead horse then.  :-)

Perhaps it can be fixed. I don't know.

> I spotchecked just a few projects (activeMQ, Roller, Solr, Woden) and 
> believe that all of the content has made it through your conversion ok.

Thanks, good to cast other eyes over it.

> The table under the "Project info" section is especially visually 
> confusing because there are normally quite a few blank cells -- it could 
> use borders if that's trivial; otherwise, easy to catch in a post 
> conversion cleanup.

The site uses CSS so that should be easy to enhance later.
Perhaps the stylesheets/site.vsl will need to add some
extra class attributes.

> And a table of contents at the top of the page would be nice if Anakia 
> can generate one.

AFAIK it does not. Specific pages at /dev/ for example
have a manual Table of Contents.

> One curious side note: I notice on linux that the generated project file 
> has a mix of \n and \r \n line endings. Do you see the same? --It isn't 
> in the source xml, so isn't a side effect of your conversion.

Hmmm, yes i do. There seem to be DOS end-of-line markers
only for text lines within <p> and <li> elements, etc.

This must be fixed because cannot do 'svn add' with such
a mess.

No idea where they come from. The xdocs2/stylesheets/site.vsl
is clear of them.

Would someone familiar with Velocity/Anakia please help.

-David

---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message