incubator-general mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen McConnell <mcconn...@apache.org>
Subject Re: Common naming accross policy/process/roles
Date Tue, 28 Oct 2003 08:31:58 GMT


Nicola Ken Barozzi wrote:

> Berin Lautenbach wrote:
>
>> Nicola Ken Barozzi wrote:
>>
>>> I also want to make sure that we well know where things stand in 
>>> every incubation moment, as there has been enough confusion 
>>> withdouble-triple PMC concurrent votes.
>>
>>
>> +1
>>
>>> That said, I also think that we need *one* document to guide us, and 
>>> all the rest should be simply docs that complement it as HOWTOs.
>>
>>
>> +1 - although whether they are HOWTOs or some other format would I 
>> think depend on appropriateness of content.
>>
>> Any objections to my changing the "Incubation" heading on the main 
>> side bar down into "Incubator Policy" and "Incubator Guideance".  The 
>> first has an intro page discussing what the policy is for and a 
>> single document (the policy) and the second has the other documents 
>> with an intro page discussing what they are for?
>
>
> Hmmm... policy... guidance... really, I may seem paranoid, but they 
> don't spark a clear distinction in my head.


Policy == rules of the game.
Guidence == suggestions on how to play the game

>
>
> I want to see a single document, not more. Just one.
> Call it Process, call it Policy, call it Rules, but just one.
>
> Proposal:
>
>  - add a HOWTO section
>  - rename Process_Description to Incubation_HOWTO
>  - make a HOWTO doc from each paragraph of ROLES_AND_RESPONSIBILITIES
>
> Why an I so keen on "HOWTO"? Because HOWTOS are well known to be 
> non-normative. 


I disagree.

A general guidance document is talking about a typical incubation 
process and is targeted towards someone who is thinking about 
involvement in such a process.  Policies are the set of rules that 
provide the framework for consistency - its the rules that PMC and 
incubator project participants are working under between comencement and 
exit.

Cheers, Steve.

-- 

Stephen J. McConnell
mailto:mcconnell@apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: general-unsubscribe@incubator.apache.org
For additional commands, e-mail: general-help@incubator.apache.org


Mime
View raw message