incubator-flume-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lior Harel <harel.l...@gmail.com>
Subject Re: nodes configuration is lost after master is restarted
Date Tue, 30 Aug 2011 16:21:20 GMT
you're right, changing the configuration solved my problems. should the
documentation note that the default dir is a temporary one?

On Tue, Aug 30, 2011 at 4:33 PM, Joe Crobak <joecrow@gmail.com> wrote:

> Per the user guide [1], I suspect the property that you need to update is
> flume.master.zk.logdir.  It defaults to:
>
>   <property>
>     <name>flume.master.zk.logdir</name>
>     <value>/tmp/flume-${user.name}-zk</value>
>     <description>The base directory in which the ZBCS stores
> data.</description>
>   </property>
>
> which might be cleaned up at any time by the OS.
>
> You probably also want to set FLUME_PID_DIR in flume-env.sh, because this
> also defaults to a location in
> /tmp: flume:MASTERPID=${FLUME_PID_DIR:="/tmp"}/flumemaster.pid
>
>
> [1]
> http://archive.cloudera.com/cdh/3/flume/UserGuide/index.html#_configuring_the_zbcs
>
>
> On Mon, Aug 29, 2011 at 6:11 AM, Lior Harel <harel.lior@gmail.com> wrote:
>
>> Hi All,
>> I am running a single master with a few agents and a single collector, I
>> noticed that after restarting the flume master it seems to lost all previous
>> configuration.
>> I am running in ZBCS mode, without any changes to the default
>> configuration. can you help me making the configuration persistent?
>>
>> Thanks
>> Lior
>>
>
>

Mime
View raw message