incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: Apache Flex 4.9 Release Candidate 3
Date Tue, 18 Dec 2012 22:28:21 GMT



On 12/18/12 2:05 PM, "Om" <bigosmallm@gmail.com> wrote:

> On Tue, Dec 18, 2012 at 1:58 PM, Justin Mclean
> <justin@classsoftware.com>wrote:
> 
>> Hi,
>> 
>>>  Which is useful, but somewhat disturbing information as it
>>> potentially increases the number of possible rendering environments.
>> 
>> I don't think we can possible test every combination here that's:
>> OS version (at least 2) x compile for FP (x8) x run in FP versions (x8) x
>> supported locales (x22) x AIR (x5) = 14000+ combinations :-)
>> 
>> 
> I think we decided that we will test only en_US because that is what we
> have baselines for.
> And it makes logical sense to tie a FP runtime to its corresponding AIR
> runtime (ex. 11.4 goes with AIR 3.4)
> 
> With these assumptions, the number of combinations would be more like:
> 
> OS version (at least 2) x compile for FP/AIR (x8) = 16 combinations.
> 
> More manageable, IMHO.
> 
I think Nick showed that we need the run-in dimension in order to be
complete.  Really though, having tested 11.5 last night and 11.1 the night
before, the probability of it not working for 11.2, 11.3, and 11.4 is very
small, such that it probably isn't worth our time to try them.  We can
probably just test 11.1 (which was the 4.6 certified version) and the latest
player (in this case 11.5) and say in the readme that we "expect" that it
will work on other versions.  Bonus if you want to try 10.2 so we fully
bracket the range.

-- 
Alex Harui
Flex SDK Team
Adobe Systems, Inc.
http://blogs.adobe.com/aharui


Mime
View raw message