incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carol Frampton <cfram...@adobe.com>
Subject Re: [VOTE] Apache Flex 4.9 Release Candidate 4
Date Tue, 18 Dec 2012 16:35:30 GMT
-1  The SDK is almost there but now that the README mentions the installer
I will vote -1 until the installer is ready to go out at the same time.

I built the src kit and I built frameworks in the binary kit.  I built FB
SDKs with both directories using
ide/flashbuilder/makeApacheFlexForFlashBuilder.sh and tested both in Flash
Builder 4.7 with mini AIR and FP apps.  All checked out fine.


1. The README needs more work.

- The AIR download URL was edited to be 3.4 but this was added which is
inconsistent:

        This version of Apache Flex was certified for use with AIR 3.1,
and is compatible
        with versions 3.1 through 3.5.

- Once fixed, we are saying we certified with FP11.1 and AIR 3.4 and we're
compatible with other versions.  Is that what we decided we want to say?

- We need to be more specific about how you use different versions of
FlashPlayer and AIR.  If I was reading the README I'd want to know what
that really means. What does it mean if I have a source kit?  What does it
mean if I have a binary kit? Do I need to rebuild to use another version
and if so how do I do that?
 

- Same as above for non-en_US locales for both types of kit.  The README
should include some information for the source kit, on how to build those
locales, and how to set the locale.  The binary kit includes all the
locales.  ant main does not build anything other than the default locale
(I assume that works if the default isn't en_US but I've never tried it
myself).

2.  I removed the exec of the svn command line app from the batik build
file.  I fixed the manifest for batik-all-flex.jar.

Carol

On 12/17/12 7 :36PM, "Justin Mclean" <justin@classsoftware.com> wrote:

>Hi,
>
>This is a  Adobe Flex 4.9.0 release candidate 4. Please see the
>RELEASE_NOTES and the README.
>
>Fixed in this release candidate:
>- Addition information in README
>- Fix issue with apache.swc not containing classes
>- Remove DISCLAIMER and incubating from the package source files
>- Minor changes to build script
>- Fixed packaging so that the SDK works with Flash Builder 4.7
>
>The release candidate can be found here;
>http://people.apache.org/~jmclean/Apache%20Flex%204.9.0%20Release%20Candid
>ate%204/
>
>Before voting please review the section,"What are the ASF requirements on
>approving a release?", at:
>http://www.apache.org/dev/release.html#approving-a-release
>
>Please vote to approve this release:
>+1 Approve the release
>-1 Veto the release (please provide specific comments to why)
>
>This vote will be open for at least 72 hours. The vote passes if there is:
>- At least 3 +1 votes from the IPMC
>- More positive votes than negative votes
>
>When voting please indicate what platform and IDE  you compiled and
>tested the SDK with.
>
>If we are not made a top level project at the next ASF board meeting this
>week, this RC will not be released but we'll create a new incubating RC
>and vote on that.
>
>Thanks,
>Justin


Mime
View raw message