incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carol Frampton <cfram...@adobe.com>
Subject Re: Apache Flex 4.9 RC 2
Date Fri, 14 Dec 2012 19:00:13 GMT
Justin,

I worked on the kit this morning.  Here is where I am leaving it:

1.  The build number was not set in RC2 when you build it.  You can see
this because the build number is not set in flex-sdk-description.xml (and
there none of the Version.as files).  See build/build_release.sh for how I
did it for 4.8.0.
2.  apache.swc and experimental.swc were missing from the binary kit so I
added them.
3.  I add a java source and target of 1.6 to the compile target in the
batik build file so if you build the compiler with Java 1.7, FlashBuilder
4.7 seems happy.
4.  makeApacheFlexForFlashBuilder.sh works with the new binary kit which
includes #2 and #3 and FB 4.7.
5.  We did not make a decision on what version of AIR to recommend/run
mustella with.  I think AIR 3.1 is too old.  I've been using AIR 3.4 for
about a month now.  I'm pretty sure AIR 3.5 is just about to be released.
I think we need to pick a newer version, update the README and the URL in
makeApacheFlexForFlashBuilder.sh/bat and update our AIR_HOME global
variables/env.properties files to use it.  The installer should be updated
as well.

Carol


Mime
View raw message