incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carol Frampton <cfram...@adobe.com>
Subject Re: Apache Flex 4.9 RC 2
Date Thu, 13 Dec 2012 14:39:11 GMT
Justin,

I went thru all the same steps yesterday.  I sent mail to the FlashBuilder
team in India before I left yesterday with essentially all the info you
have in your email.  I was hoping to find a response this morning but I
did not.  If I don't hear back by tomorrow I will ask again.  I suspect FB
4.6 has the same issue.

Carol


On 12/12/12 7 :56PM, "Justin Mclean" <justin@classsoftware.com> wrote:

>Hi,
>
>> Yup, that's the FB/Java 1.7 issue I told you about.  I haven't debugged
>>it
>> but I've certainly run into it.
>
>After a little more investigation it seem it's a Flash builder issue,
>Flash Builder uses JRE 1.6 even if you configure it for  JRE 1.7.
>
>Looking in the config (about Flash Builder, click on installation details
>then configuration) you see:
>-vm /System/Library/Frameworks/JavaVM.framework
>
>On my version of OSX (10.7.5)  this:
>/System/Library/Frameworks/JavaVM.framework/Commands/java -version
>
>Gives:
>java version "1.6.0_37"
>Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909)
>Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)
>
>Which is not the default JRE set in Java preferences (in system
>preferences). Adding a -vm option in the flashbuilder.ini file has no
>effect and setting the JRE to be 1.7 in in preferences in Installed JRE's
>also has no effect. So it looking like a Flash Builder issue which we may
>not be able to do anything about.
>
>I've not tried Flash Builder 4.7 but the release notes for OSX say it
>only supports Java 1.6 not Java 1.7.
>
>Has anyone got FB 4.6 to run with Java 1.7 on OSX?
>
>Thanks,
>Justin


Mime
View raw message