incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Carol Frampton <cfram...@adobe.com>
Subject Re: Apache Flex 4.9 RC 2
Date Wed, 12 Dec 2012 14:46:35 GMT


On 12/12/12 2 :21AM, "Justin Mclean" <justin@classsoftware.com> wrote:

>Hi,
>
>I've made a RC 2 release build, it compiles and passes the checkin tests.
>
>It can be found here:
>http://people.apache.org/~jmclean/Apache%20Flex%204.9.0%20Release%20Candid
>ate%202/
>
>However I've run into a couple of issues.
>
>1. ant creates FB config files in (/ide/flashbuilder), I assume this is a
>FB 4.7 feature. Currently I can only run FB 4.6 as my 4.7 trial has
>expired and Adobe not sent me my new serial number yet.
>
>This can be fixed by editing the flex-config.xml in the framework
>directory and replacing {playergolobalHome} to be libs/player.
>
>Should this be fixed or should the build script assume users are using FB
>4.7?

I'm not sure what you're asking.  This files are for internal use if you
want to use your development tree as a FB SDK.   I use the make-sdk target
for either FB 4.6 or 4.7.  These files aren't on the kit are they?


>
>2. When compiling form FB 4.6 batik causes a RTE
>
>!ENTRY com.adobe.flexbuilder.project 4 43 2012-12-12 17:59:32.258
>!MESSAGE Uncaught exception in compiler
>!STACK 0
>java.lang.UnsupportedClassVersionError:
>org/apache/flex/forks/batik/css/parser/Parser
>	at flash.css.StyleParser.init(StyleParser.java:190)
>	at flash.css.StyleParser.<init>(StyleParser.java:96)
>	at flash.css.StyleSheet.parse(StyleSheet.java:125)
>	at 
>flex2.compiler.css.StylesContainer.processStyleSheet(StylesContainer.java:
>863)
>	at 
>flex2.compiler.css.StylesContainer.loadDefaultStyles(StylesContainer.java:
>795)
>	at flex2.tools.PreLink.processMainUnit(PreLink.java:436)
>	at flex2.tools.PreLink.run(PreLink.java:106)
>	at flex2.compiler.CompilerAPI.compile(CompilerAPI.java:1594)
>	at flex2.tools.oem.Application.compile(Application.java:1357)
>	at flex2.tools.oem.Application.recompile(Application.java:1295)
>	at flex2.tools.oem.Application.compile(Application.java:894)
>	at 
>flex2.tools.flexbuilder.BuilderApplication.compile(BuilderApplication.java
>:367)
>	at 
>com.adobe.flexbuilder.multisdk.compiler.internal.ASApplicationBuilder$MyBu
>ilder.mybuild(ASApplicationBuilder.java:319)
>	at 
>com.adobe.flexbuilder.multisdk.compiler.internal.ASApplicationBuilder.buil
>d(ASApplicationBuilder.java:129)
>	at 
>com.adobe.flexbuilder.multisdk.compiler.internal.ASBuilder.build(ASBuilder
>.java:198)
>	at 
>com.adobe.flexbuilder.multisdk.compiler.internal.ASItemBuilder.build(ASIte
>mBuilder.java:70)
>	at 
>com.adobe.flexbuilder.project.compiler.internal.FlexProjectBuilder.buildIt
>em(FlexProjectBuilder.java:607)
>	at 
>com.adobe.flexbuilder.project.compiler.internal.FlexProjectBuilder.build(F
>lexProjectBuilder.java:382)
>	at 
>com.adobe.flexbuilder.project.compiler.internal.FlexIncrementalBuilder.bui
>ld(FlexIncrementalBuilder.java:187)
>	at 
>org.eclipse.core.internal.events.BuildManager$2.run(BuildManager.java:728)
>	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
>	at 
>org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java
>:199)
>	at 
>org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java
>:239)
>	at 
>org.eclipse.core.internal.events.BuildManager$1.run(BuildManager.java:292)
>	at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
>	at 
>org.eclipse.core.internal.events.BuildManager.basicBuild(BuildManager.java
>:295)
>	at 
>org.eclipse.core.internal.events.BuildManager.basicBuildLoop(BuildManager.
>java:351)
>	at 
>org.eclipse.core.internal.events.BuildManager.build(BuildManager.java:374)
>	at 
>org.eclipse.core.internal.events.AutoBuildJob.doBuild(AutoBuildJob.java:14
>3)
>	at 
>org.eclipse.core.internal.events.AutoBuildJob.run(AutoBuildJob.java:241)
>	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
>
>Now I assume this is a Java version mismatch, I'm compiling with Java
>version 1.7.0_10 and eclipse/FB seems to be configured to use 1.7.0_10
>but something is obviously not quite right.

Yup, that's the FB/Java 1.7 issue I told you about.  I haven't debugged it
but I've certainly run into it.

Carol


Mime
View raw message