incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Harui <aha...@adobe.com>
Subject Re: [Mustella] 90 tests failed
Date Tue, 11 Dec 2012 04:08:43 GMT
I have fixes for all failures that aren't related to ADG, Charts or
ResourceManager.  It required some changes to the SDK so a full mustella run
needs to happen tonight to verify.


On 12/10/12 10:02 AM, "Alex Harui" <aharui@adobe.com> wrote:

> I have found flaws in the StyleManager tests (also timing/event issues).  I
> will test those out shortly.
> 
> 
> On 12/10/12 9:28 AM, "Alex Harui" <aharui@adobe.com> wrote:
> 
>> OK, thanks.
>> 
>> 
>> On 12/10/12 3:22 AM, "Frédéric THOMAS" <webdoublefx@hotmail.com> wrote:
>> 
>>> @Alex
>>> I don't know what happened this morning but I had what I described above in
>>> my working copy, looking at the svn, it wasn't like that, well, anyway, this
>>> one is fixed, the 2 others as well, it means the 3 last of my 90 failed
>>> tests are fixed and committed [1].
>>> 
>>> The 2 last, were a bit tricky for me as I don't get used to deal with the
>>> mxmlc directly, usually I compile my stuffs with maven.
>>> 
>>> 
>>> - Fred
>>> 
>>> [1] http://svn.apache.org/viewvc?view=revision&revision=1419339
>>> 
>>> -----Message d'origine-----
>>> From: Frédéric THOMAS
>>> Sent: Monday, December 10, 2012 8:12 AM
>>> To: flex-dev@incubator.apache.org
>>> Subject: Re: [Mustella] 90 tests failed
>>> 
>>> @Alex,
>>> 
>>> it was like that :
>>> 
>>>                 <RunCode code="ed4.addEventListener(ResourceEvent.ERROR,
>>> handleErrorEvent)" />
>>>                 <RunCode code="ed4.addEventListener(ResourceEvent.COMPLETE,
>>> handleCompleteEvent)" />
>>>                 <WaitForEvent
>>> target="mx.resources::ResourceManager.getInstance()" eventName="change"
>>> timeout="1000" />
>>>                 <RunCode
>>> 
> 
code="ed4=ResourceManager.getInstance().loadResourceModule('assets/bundles/cu>>
>
> s
>>> tom/resMod_loadResourceModule_enUS_bundle1_004.swf')"
>>> />
>>>                 <RunCode code="ed5.addEventListener(ResourceEvent.ERROR,
>>> handleErrorEvent)" />
>>>                 <RunCode code="ed5.addEventListener(ResourceEvent.COMPLETE,
>>> handleCompleteEvent)" />
>>>                 <WaitForEvent
>>> target="mx.resources::ResourceManager.getInstance()" eventName="change"
>>> timeout="1000" />
>>>                 <RunCode
>>> 
> 
code="ed5=ResourceManager.getInstance().loadResourceModule('assets/bundles/cu>>
>
> s
>>> tom2/resMod_loadResourceModule_enUS_bundle1_005.swf')"
>>> />
>>>                 <AssertMethodValue
>>> method="value=ResourceManager.getInstance().getLocales().length" value="1"
>>> />
>>>                 <AssertMethodValue
>>> method="value=ResourceManager.getInstance().getLocales()[0]" value="en_US"
>>> />
>>>                 <AssertMethodValue
>>> method="value=ResourceManager.getInstance().getString('bundle1','SHUTDOWN')"
>>> value="Shut down" />
>>>                 <AssertMethodValue
>>> method="value=ResourceManager.getInstance().getString('bundle1',
>>> 'SHUTDOWN2')" valueExpression="value=null" />
>>> 
>>> It was a sequence problem, I moved the resourceManager loadResourceModule
>>> before to add eventListeners to them , I did that before but it didn't work
>>> because it's was also a timing problem, it passed in the degugger but not in
>>> live, I just changed its timeout from 1000 to 2000
>>> 
>>> -----Message d'origine-----
>>> From: Om
>>> Sent: Monday, December 10, 2012 7:44 AM
>>> To: flex-dev@incubator.apache.org
>>> Subject: Re: [Mustella] 90 tests failed
>>> 
>>> 1. Create a new file under bin-debug/debug.html with nothing in it.
>>> 2.  Create a new debug configuration.  In the "URL or path to launch",
>>> point it to bin-debug/html
>>> 2.  Run the debug configuration
>>> 3.  Flash Builder launches the bin-debug/debug.html file and waits to
>>> connect to the running application.  But since there is no swf to connect
>>> to,  in this mode, Flash Builder will debug any swf.
>>> 4.  Open the swf that you want to debug, right click and select 'Debugger'.
>>> Select 'Localhost'
>>> 
>>> You should now be in Flash Builder debugger mode.  Obviously, you need to
>>> source code for the swf somewhere in your project's source paths if you
>>> want to have breakpoints.
>>> 
>>> Hope this helps!
>>> 
>>> Thanks,
>>> Om
>>> 
>>> On Sun, Dec 9, 2012 at 10:08 PM, Alex Harui <aharui@adobe.com> wrote:
>>> 
>>>> 
>>>> 
>>>>> 
>>>>> I used it once only and it's a bit a pain but ok, yes, I'll do that.
>>>>> 
>>>> Supposedly, there is a way to get FlashBuilder to connect to any SWF as
>>>> well.  I don't know it though.
>>>> 
>>>> --
>>>> Alex Harui
>>>> Flex SDK Team
>>>> Adobe Systems, Inc.
>>>> http://blogs.adobe.com/aharui
>>>> 
>>>> 
>>> 

-- 
Alex Harui
Flex SDK Team
Adobe Systems, Inc.
http://blogs.adobe.com/aharui


Mime
View raw message