incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cyrill Zadra <cyrill.za...@gmail.com>
Subject Re: [Falcon] Unit tests failing
Date Thu, 06 Dec 2012 00:36:51 GMT
Hi Mike

Had the same problem after I used "ant wipe,main".

But you can solve it when you run the tests with the FLEX_HOME as java
system property - ( -DFLEX_HOME=C:/dev/tools/flex/apache-flex-4.8.0 )

Cyrill

On Wed, Dec 5, 2012 at 7:40 AM, Alex Harui <aharui@adobe.com> wrote:
> If you don’t copy sdk you need flex_home environment var. I will be making improvement
in the build scripts today.
>
> Sent from my Motorola ATRIX™ 4G on AT&T
>
>
> -----Original message-----
> From: Michael Schmalle <apache@teotigraphix.com>
> To: "flex-dev@incubator.apache.org" <flex-dev@incubator.apache.org>
> Sent: Wed, Dec 5, 2012 11:06:28 GMT+00:00
> Subject: [Falcon] Unit tests failing
>
>
> Hi,
>
> I have reinstalled things for the third time here and I cannot get the
> unit tests to pass.
>
> Have any of you Falcon devs done a complete wipe and rebuild on the
> compiler and compile.tests? I think there is an error in the build
> files with the sdk location in the tests pointing to the compile
> generated sdk.
>
> Example, this stuff is using the SDK constant which is currently holding;
>
> ... \svn\apache\flex\falcon\trunk\compiler\generated\dist\sdk
>
> libraries.add(new File(FilenameNormalization.normalize(SDK +
> "\\frameworks\\libs\\player\\11.1\\playerglobal.swc<file://\\frameworks\\libs\\player\\11.1\\playerglobal.swc>")));
> ....
>
> The above folder doesn't exist anymore since we are not copying the
> full sdk to the compiler folder.
>
> Thus when the tests parses for the FileNode, its a single dead node.
>
> I don't know how to fix this but it needs to be looked at by someone
> that knows the build system.
>
> Mike
>
>
> --
> Michael Schmalle - Teoti Graphix, LLC
> http://www.teotigraphix.com
> http://blog.teotigraphix.com
>

Mime
View raw message