incubator-flex-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik de Bruin <e...@ixsoftware.nl>
Subject Re: Falcon compiler(.tests) building
Date Sun, 18 Nov 2012 18:10:40 GMT
I do see some warnings on the 'compiler' build:

"[javac] /Users/erik/Documents/ApacheFlex/svn/apacheFlex-falcon/compiler/build.xml:415:
warning: 'includeantruntime' was not set, defaulting to
build.sysclasspath=last; set to false for repeatable builds"

When I do a 'wipe' and build again, I see one specific warning (other
than a couple of the above):

"Warning: /Users/erik/Documents/ApacheFlex/svn/apacheFlex-sdk/ant/lib
does not exist."

Help?

EdB


On Sun, Nov 18, 2012 at 6:55 PM, Erik de Bruin <erik@ixsoftware.nl> wrote:
> Hi,
>
> I have followed the various instructions and was able to successfully
> build the Falcon compiler. Along the way I encountered several issues
> that are not yet documented (I'm on OS X 10.8):
>
> - I needed to edit the 'build.xml' file on line 50, to point the
> 'sdk.branch' property to the correct location of the SDK on my system;
> - when trying to use the mxmlc on a project, I got 'permission
> denied'. Setting the executable bit on the file corrected that;
>
> After that I was able to run from the command line and successfully
> build "Hello.as", which ran fine in the standalone Flash debugger.
>
> So I proceed to get the projects 'compiler' and 'compiler.tests' to
> work in in Eclipse. After importing them, I get a 'problem' on each
> one:
> - on 'compiler', I got a message about 'ANT_JAR', which after I
> re-created that variable in the project build path and pointed it to
> 'ant.jar' on my system, went away;
> - on 'compiler.tests' I got "missing required library
> 'lib/junit-4.10.jar'". Editing the entry in the 'build path/Libraries'
> fixed that.
>
> I got 'build.xml' on 'compiler' working in Eclipse after adding:
>
> <property name="env.JFLEX_JAR"
> value="/usr/share/java/jflex-1.4.3/lib/JFlex.jar"/>
>
> Then I ran 'build.xml' on 'compiler.tests' and that completed, but
> with plenty of FAILED tests (which I guess is expected?).
>
> So, my environment seems to be set up. Now: how can I help?
>
> Note: I'm a noob on the topic of compilers, but I can copy-paste like
> a Boss, so I'm sure you can use me ;-) Point me to the code and put me
> to work!
>
> EdB
>
>
>
> --
> Ix Multimedia Software
>
> Jan Luykenstraat 27
> 3521 VB Utrecht
>
> T. 06-51952295
> I. www.ixsoftware.nl



-- 
Ix Multimedia Software

Jan Luykenstraat 27
3521 VB Utrecht

T. 06-51952295
I. www.ixsoftware.nl

Mime
View raw message